PAT甲级 -- 1126 Eulerian Path (25 分)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

24分:有一个测试点没过。

#include <iostream>
#include <string>
#include <vector>
using namespace std;

const int MAXN = 501;
int n, m;  //顶点数和边数
int g[MAXN][MAXN] = {0}; //无边是0,有边是1
bool visit[MAXN];  //访问数组
int indegree[MAXN] = {0};  //度数组
int even = 0, odd = 0; // 统计奇数和偶数顶点


void dfs(int node)
{
	visit[node] = true;
	for (int i = 1; i <= n; i++)
	{
		if (visit[i] == false && g[node][i] == 1)
		{
			dfs(i);
		}
	}
}
int main()
{
	scanf("%d%d", &n, &m);  
	for (int i = 0; i < m; i++)
	{
		int u, v;
		scanf("%d %d", &u, &v);
		g[u][v] = g[v][u] = 1;
		indegree[u]++;
		indegree[v]++;
	}
	//打印度数
	printf("%d", indegree[1]);
	if (indegree[1]%2 == 1) odd++;
	else if(indegree[1]%2 == 0) even++;

	for (int i = 2; i <= n; i++)
	{
		if (indegree[i]%2 == 1) odd++;
		else if(indegree[i]%2 == 0) even++;
		printf(" %d", indegree[i]);
	}
	printf("\n");
	
	int cnt = 0; //连通分量个数
	visit[1] = true;
	for (int i = 1; i <= n; i++)
	{
		if (visit[i] == false)
		{
			dfs(i);
			cnt++;

		}
	}
		

	if (cnt == 1)
	{
		if (odd == 2)
		{
			printf("Semi-Eulerian\n");
		}else if(even == n)
		{
			printf("Eulerian\n");
		}else
		{
			printf("Non-Eulerian\n");
		}
	}else
	{
		printf("Non-Eulerian\n");
	}

		
	
	return 0;
}
	

 柳神代码:

学习:

1. 判断整个图是否连通,可以从第一个顶点开始dfs,对与第一个顶点可以到的顶点进行标记,若最后标记 == 顶点个数,说明连通!

2. 控制输出的方式

#include <iostream>
#include <vector>
using namespace std;
vector<vector<int> > v;
vector<bool> visit;
int cnt = 0;
void dfs(int index) {
    visit[index] = true;
    cnt++;
    for (int i = 0; i < v[index].size(); i++)
        if (visit[v[index][i]] == false)
            dfs(v[index][i]);
}
int main() {
    int n, m, a, b, even = 0;
    scanf("%d%d", &n, &m);
    v.resize(n + 1);
    visit.resize(n + 1);
    for (int i = 0; i < m; i++) {
        scanf("%d%d", &a, &b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    for (int i = 1; i <= n; i++) {
        if (i != 1) printf(" ");
        printf("%d", v[i].size());
        if (v[i].size() % 2 == 0) even++;
    }
    printf("\n");
    dfs(1);
    if (even == n && cnt == n)
        printf("Eulerian");
    else if(even == n - 2 && cnt == n)
        printf("Semi-Eulerian");
    else
        printf("Non-Eulerian");
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值