hdoj 2824 The Euler function 【欧拉函数】

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4520    Accepted Submission(s): 1880


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

Sample Input
  
  
3 100
 

Sample Output
  
  
3042
 

分析:

题意就是求出从n~m的数的质数的个数的和。

代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#define maxn 3000001
using namespace std;
int n,m;
int gg[maxn];

void euler()
{
     memset(gg,0,sizeof(gg));
     gg[1]=1;
     for(int i=2;i<maxn;i++)
     if(!gg[i])
     for(int j=i;j<maxn;j+=i)
      {
       if(!gg[j])
       gg[j]=j;
       gg[j]=gg[j]/i*(i-1);
      }
}

int main()
{
      euler();// 这一点特别注意,不要把函数调用放在while里面 否则会超时。 
    while(scanf("%d%d",&n,&m)!=EOF)
    {
     long long sum=0;// 此处用long long 和__int64 都可以。 
     for(int i=n;i<=m;i++)
     {
      if(gg[i])
      sum+=gg[i];
     }
     printf("%lld\n",sum);
    }
    return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值