周赛 5 【思路题】

E - 楼下水题
Crawling in process... Crawling failed Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Given an array with n integers, and you are given two indices i and j (i ≠ j) in the array. You have to find two integers in the range whose difference is minimum. You have to print this value. The array is indexed from 0 to n-1.

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case contains two integers n (2 ≤ n ≤ 105) and q (1 ≤ q ≤ 10000). The next line contains n space separated integers which form the array. These integers range in [1, 1000].

Each of the next q lines contains two integers i and j (0 ≤ i < j < n).

Output

For each test case, print the case number in a line. Then for each query, print the desired result.

Sample Input

2

5 3

10 2 3 12 7

0 2

0 4

2 4

2 1

1 2

0 1

Sample Output

Case 1:

1

1

4

Case 2:

1

分析:

求区间最小值。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;

int pp[100005];
int cc[1005];
int n,m;

void solve()
{
	int a,b;
	scanf("%d%d",&a,&b);
	if(b-a+1>1000)
	{
		printf("0\n");
		return;
	}
	memset(cc,0,sizeof(cc));
	for(int i=a;i<=b;i++)
	++cc[pp[i]];
	int ccase=-1,dis=10005,tp=0;
	for(int i=0;i<1005&&tp<=b-a;++i)
	{
		if(cc[i]>1)
		{
			dis=0;
			break;
		}
		if(cc[i])
		{
			++tp;
			if(ccase!=-1&&i-ccase<dis)
			{
				dis=i-ccase;
			}
			ccase=i;
		}
	}
	printf("%d\n",dis);
}

int main()
{
	int t;
	scanf("%d",&t);
	int cnt=0;
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int j=0;j<n;++j)
		{
			scanf("%d",pp+j);
		}
		printf("Case %d:\n",++cnt);
		while(m--)
		{
			solve();
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值