poj 2549 Sumsets 【二分&&模拟】

9 篇文章 0 订阅
3 篇文章 0 订阅
Sumsets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10005 Accepted: 2737

Description

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input

5
2 
3 
5 
7 
12
5
2 
16 
64 
256 
1024
0

Sample Output

12
no solution
分析:
先用俩层for循环找出最大的和第二最大的,然后用二分求剩下两个就oK了。
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<iostream>
#include<stack>
#include<vector>
#include<cstdlib>
#define SI(x) scanf("%d",&x)
#define PI(x) cout<<x<<endl
#define FOR(i,x,n) for(i=x;i<n;i++)
#define mem(x,y) memset(x,y,sizeof(x))
#define O_O(x) while(x--)
#define SS(x) scanf("%s",x)
#define SC(x) cin>>x
#define SL(x) cin>>x
#define PL(x) cout<<x<<endl
#define PS(x) cout<<x<<endl
#define PC(x) cout<<x<<endl
#define R return
#define inf -600000000
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
using namespace std;
int pp[1010];
int main()
{
    int n;
    while(SI(n),n)
    {
        for(int i=0;i<n;i++)
            SI(pp[i]);
        sort(pp,pp+n);
        n--;
        int ans=inf;
        for(int i=n;i>=0;i--)
        {
            for(int j=n;j>=0;j--)
            {
                if(i==j)
                    continue;
                int sum=pp[i]-pp[j];
                for(int l=0,r=j-1;l<r;)
                {
                    if(pp[l]+pp[r]==sum)
                    {
                        ans=pp[i];
                        break;
                    }
                    else if(pp[l]+pp[r]>sum)
                        r--;
                    else l++;
                }
            }
            if(ans!=inf)
                break;
        }
        if(ans==inf)
            printf("no solution\n");
        else printf("%d\n",ans);
    }
    R 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值