poj 1734 Sightseeing trip hdu 1599 find the mincost route 最小环 解题报告

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 110
using namespace std;

int map[MAXN][MAXN], dist[MAXN][MAXN], pre[MAXN][MAXN];
int ans, p[MAXN], t, n, m;

void cal()
{
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++)
        {
            dist[i][j] = map[i][j];
            pre[i][j] = i;
        }
    for(int k = 1; k <= n; k++)
    {
        for(int i = 1; i <= n; i++)
        {
            if(map[k][i] == INF) continue;
            if(i == k) continue;
            for(int j = 1; j <= n; j++)
            {
                if(i == j || j == k) continue;
                if(dist[i][j] == INF || map[j][k] == INF) continue;
                int temp = dist[i][j] + map[i][k] + map[k][j];
                if(temp < ans)
                {
                    ans = temp;
                    int x = j;
                    t = 0;
                    while(x != i)
                    {
                        p[t++] = x;
                        x = pre[i][x];
                    }
                    p[t++] = i;
                    p[t++] = k;
                }
            }
        }
        for(int i = 1; i <= n; i++)
        {
            if(dist[i][k] == INF) continue;
            for(int j = 1; j <= n; j++)
            {
                if(dist[i][j] > dist[i][k] + dist[k][j])
                {
                    dist[i][j] = dist[i][k] + dist[k][j];
                    pre[i][j] = pre[k][j];
                }
            }
        }
    }
}

int main()
{
    int a, b, c;
    while(scanf("%d%d", &n, &m) != EOF)
    {
        ans = INF;
        memset(map, 0x3f, sizeof(map));
        while(m--)
        {
            scanf("%d%d%d", &a, &b, &c);
            if(c < map[a][b])
                map[a][b] = map[b][a] = c;
        }
        cal();
        if(ans == INF) printf("No solution.\n");
        else
        {
            printf("%d", p[0]);
            for(int i = 1; i < t; i++) printf(" %d", p[i]);
            printf("\n");
        }
    }
    return 0;
}

Problem Description
杭州有N个景区,景区之间有一些双向的路来连接,现在8600想找一条旅游路线,这个路线从A点出发并且最后回到A点,假设经过的路线为V1,V2,....VK,V1,那么必须满足K>2,就是说至除了出发点以外至少要经过2个其他不同的景区,而且不能重复经过同一个景区。现在8600需要你帮他找一条这样的路线,并且花费越少越好。
 

Input
第一行是2个整数N和M(N <= 100, M <= 1000),代表景区的个数和道路的条数。
接下来的M行里,每行包括3个整数a,b,c.代表a和b之间有一条通路,并且需要花费c元(c <= 100)。
 

Output
对于每个测试实例,如果能找到这样一条路线的话,输出花费的最小值。如果找不到的话,输出"It's impossible.".
 

Sample Input
  
  
3 3 1 2 1 2 3 1 1 3 1 3 3 1 2 1 1 2 3 2 3 1
 

Sample Output
  
  
3 It's impossible.

用0x3f3f3f3爆int了,所以改成1000000

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define INF 1000000
#define MAXN 110
using namespace std;

int map[MAXN][MAXN], dist[MAXN][MAXN], pre[MAXN][MAXN];
int ans, p[MAXN], t, n, m;

void cal()
{
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++)
        {
            dist[i][j] = map[i][j];
            pre[i][j] = i;
        }
    for(int k = 1; k <= n; k++)
    {
        for(int i = 1; i <= n; i++)
        {
            if(map[k][i] == INF) continue;
            if(i == k) continue;
            for(int j = 1; j <= n; j++)
            {
                if(i == j || j == k) continue;
                if(dist[i][j] == INF || map[j][k] == INF) continue;
                int temp = dist[i][j] + map[i][k] + map[k][j];
                if(temp < ans)
                {
                    ans = temp;
                    int x = j;
                    t = 0;
                    while(x != i)
                    {
                        p[t++] = x;
                        x = pre[i][x];
                    }
                    p[t++] = i;
                    p[t++] = k;
                }
            }
        }
        for(int i = 1; i <= n; i++)
        {
            if(dist[i][k] == INF) continue;
            for(int j = 1; j <= n; j++)
            {
                if(dist[i][j] > dist[i][k] + dist[k][j])
                {
                    dist[i][j] = dist[i][k] + dist[k][j];
                    pre[i][j] = pre[k][j];
                }
            }
        }
    }
}

int main()
{
    int a, b, c;
    while(scanf("%d%d", &n, &m) != EOF)
    {
        ans = INF;
        for(int i = 0; i < MAXN; i++) for(int j = 0; j < MAXN; j++) map[i][j] = INF;
        //memset(map, 0x3f, sizeof(map));
        while(m--)
        {
            scanf("%d%d%d", &a, &b, &c);
            if(c < map[a][b])
                map[a][b] = map[b][a] = c;
        }
        cal();
        if(ans == INF) printf("It's impossible.\n");
        else
        {
            printf("%d\n", ans);
            /*printf("%d", p[0]);
            for(int i = 1; i < t; i++) printf(" %d", p[i]);
            printf("\n");*/
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值