【题解】poj1734[CEOI1999][2018.8.24校赛 最短路 A]Sightseeing trip floyd

81 篇文章 0 订阅

题目链接

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, …, y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,…,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+…+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string ‘No solution.’ in case there isn’t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2


大意是求无向图的最小环。采用floyd算法,当外层循环刚开始时,dis[i,j]保存“经过编号1不超过k-1的节点”从i到j的最短路长度。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int N=310;
int n,m,dis[N][N],mp[N][N],pos[N][N],ans=0x3f3f3f3f;
vector<int>path;
void get_path(int i,int j)//得到最小环路径 
{
	if(!pos[i][j])return;
	get_path(i,pos[i][j]);
	path.push_back(pos[i][j]);
	get_path(pos[i][j],j);
}
int main()
{
	//freopen("in.txt","r",stdin);
    scanf("%d%d",&n,&m);
    memset(mp,0x3f,sizeof(mp));
    for(int i=1;i<=n;i++)mp[i][i]=0;
    int u,v,w;
	for(int i=1;i<=m;i++)
    {
    	scanf("%d%d%d",&u,&v,&w);
    	mp[u][v]=mp[v][u]=min(mp[u][v],w);
	}
	memcpy(dis,mp,sizeof(mp));
	for(int k=1;k<=n;k++){
	    for(int i=1;i<k;i++)
	        for(int j=i+1;j<k;j++)//枚举比k小的两个端点 
	            if((long long)dis[i][j]+mp[j][k]+mp[k][i]<ans)//i->j->k的环 
	            {
	            	ans=(long long)dis[i][j]+mp[j][k]+mp[k][i];
	            	path.clear();
	            	path.push_back(i);
	            	get_path(i,j);//找到i->j路径上的所有点 
	            	path.push_back(j);
	            	path.push_back(k);
				}
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(dis[i][j]>dis[i][k]+dis[k][j])
                {
                	dis[i][j]=dis[i][k]+dis[k][j];
                	pos[i][j]=k;//k在路径i->j上 
				}
    }
    if(ans==0x3f3f3f3f)puts("No solution.");
    else for(vector<int>::iterator it=path.begin();it!=path.end();it++)
        printf("%d ",*it);
    puts("");
    return 0;
} 

总结

无向图的最小环问题可以用floyd求解。有向图的最小环问题可以用堆优化的dijkstra算法求解,枚举起点s,s一定是第一个被从堆里取出来的节点,扫描s的所有出边,扩展、更新完成后,令d[s]=+∞。当s第二次被从堆中取出时,d[s]就是经过点s的最小环长度。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值