hiho1234--Fractal(高精度比较问题)

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述


This is the logo of PKUACM 2016. More specifically, the logo is generated as follows:

1. Put four points A0(0,0), B0(0,1), C0(1,1), D0(1,0) on a cartesian coordinate system.

2. Link A0B0, B0C0, C0D0, D0A0 separately, forming square A0B0C0D0.

3. Assume we have already generated square AiBiCiDi, then square Ai+1Bi+1Ci+1Di+1 is generated by linking the midpoints of AiBi, BiCi, CiDi and DiAi successively.

4. Repeat step three 1000 times.

Now the designer decides to add a vertical line x=k to this logo( 0<= k < 0.5, and for k, there will be at most 8 digits after the decimal point). He wants to know the number of common points between the new line and the original logo.

输入

In the first line there’s an integer T( T < 10,000), indicating the number of test cases.

Then T lines follow, each describing a test case. Each line contains an float number k, meaning that you should calculate the number of common points between line x = k and the logo.

输出

For each test case, print a line containing one integer indicating the answer. If there are infinity common points, print -1.

样例输入
3
0.375
0.001
0.478
样例输出
-1
4
20

题目大意:给一个正方形,然后取各边的中点,连接成一个新的正方形,每次在新的正方形中重复此过程,共1000次。最后给出一条平行与y轴的线,问经过多少条边。


一道水题,怎么做在这里就不说了,写题解主要是想说明一下一个不少人容易犯的问题,就是两个double型的变量d1,d2要判断两者是否相等,d1==d2的做法是错误的,正确做法应该是|d1-d2|<x,x是多少根据题意定义,在本题,d1和d2最多取到小数点后8位,那么正确做法就是:

|d1-d2|<0.0000000001(担心精度不够的话可以多加一两个0)。


AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;

int cal(double k, double now, int num){
	if(k<now) return num;
	now+=(0.5-now)/2.0;
	return cal(k,now,num+2);
}

int judge(double k){
	double now=0.0;
	for(int i=1;i<=1001;i++){
		if(fabs(k-now)<0.0000000001) return 1;
		if(k<now) return 0;
		now+=((0.5-now)/2.0);
	}
	return 0;
}
 
int main()
{
//	freopen("1.txt","r",stdin);
	int T;
	double k;
	cin>>T;
	while(T--){
		scanf("%lf",&k);
		if(judge(k)) printf("-1\n");
		else printf("%d\n",2*cal(k,0,0));
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值