hdu 5115 Dire Wolf(区间dp)

16 篇文章 0 订阅
3 篇文章 0 订阅
Problem Description
Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra


Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.


Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by bi. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.


For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks bi they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).


As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
 


Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).


The second line contains N integers ai (0 ≤ ai ≤ 100000), denoting the basic attack of each dire wolf.


The third line contains N integers bi (0 ≤ bi ≤ 50000), denoting the extra attack each dire wolf can provide.
 


Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
 


Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
 


Sample Output
Case #1: 17
Case #2: 74


Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.
 

 题目:
有n头狼排成一排,每只狼都对相邻的狼的攻击力有加成作用,每杀死一只狼所受到的伤害为当前狼的攻击力(算上加成的部分),被杀死之后的狼对相邻的狼的攻击力的加成会被取消,同时,原先与被杀死的狼相邻的两头狼会变成相邻的狼。要求使得受到的伤害值最小,求出最小值。
solution:
dp[i][j]表示从第i头狼到第j头狼全部被杀死所受到的最小伤害。a[i]表示第i头狼的初始攻击力,b[i]表示第i头狼对相邻狼的加成值。
dp[i][j]=min(dp[i][k-1]+a[k]+dp[k+1][j])+b[i-1]+b[j+1]; (i<k<j&&j>i)
dp[i][j]=a[i]+b[i-1]+b[j+1];  (i=j)

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
ll a[300],b[300],dp[500][500];
int main()
{
    int t,n;
    scanf("%d", &t);
    for (int x = 1; x <= t; x++)
    {
        ll ans = 0;
        scanf("%d", &n);
        for (int j = 1; j <= n; j++)
            scanf("%I64d", &a[j]);
        for (int j = 1; j <= n; j++)
            scanf("%I64d", &b[j]);
        a[n + 1] = 0; b[n + 1] = 0;
        for (int i = 1; i <= n; i++)
            dp[i][i] = a[i] + b[i - 1] + b[i + 1];
        for (int p = 1; p < n; p++)
        {
            for (int i = 1; i <= n; i++)
            {
                int j = i + p;
                if (j > n)break;
                dp[i][j] = min(a[i]+dp[i + 1][j], a[j] + dp[i][j - 1]);
                for (int k = i + 1; k < j; k++)
                    dp[i][j] = min(dp[i][j], dp[i][k - 1] + a[k] + dp[k + 1][j]);
                dp[i][j] += b[i - 1] + b[j + 1];
            }
        }
        printf("Case #%d: %I64d\n", x,dp[1][n]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值