poj 2299 Ultra-QuickSort(求逆序对)

37 篇文章 0 订阅
3 篇文章 0 订阅

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6

0

solution:

求逆序对裸题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 500005
int c[maxn], n, r[maxn];
struct node
{
	int pos, val;
}a[maxn];
int cmp(node a,node b)
{
	if (a.val != b.val)return a.val < b.val;
	else return a.pos < b.pos;
}
int sum(int i)
{
	int ss = 0;
	while (i > 0)
	{
		ss += c[i];
		i -= (i&-i);
	}
	return ss;
}
void add(int i, int x)
{
	while (i <= n)
	{
		c[i] += x;
		i += (i&-i);
	}
}
int main()
{
	int   x;
	while (scanf("%d",&n)&&n)
	{
		long long ans = 0;
		memset(c, 0, sizeof(c));
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &a[i].val);
			a[i].pos = i;
		}
		sort(a + 1, a + 1 + n, cmp);
		for (int i = 1; i <= n; i++)
			r[a[i].pos] = i;//离散化
		for (int j = 1; j <= n; j++)
		{
			add(r[j], 1);
			ans +=( j - sum(r[j]));
		}
		cout << ans << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值