hdu 5670 Machine(水题)

42 篇文章 0 订阅
20 篇文章 0 订阅
Problem Description
There is a machine with  m(2m30)  coloured bulbs and a button.When the button is pushed, the rightmost bulb changes.
For any changed bulb,

if it is red now it will be green;

if it is green now it will be blue;

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 
pushed  n(1n<263)  times?
 

Input
There are multiple test cases. The first line of input contains an integer  T(1T15)  indicating the number of test cases. For each test case:

The only line contains two integers  m(2m30)  and  n(1n<263) .
 

Output
For each test case, output the colour of m bulbs from left to right.
R indicates red. G indicates green. B indicates blue.
 

Sample Input
  
  
2 3 1 2 3
 

Sample Output
  
  
RRG GR
solution:
对于从右面开始的位置i,答案都是等于n%pow(3,i)
#include<cstdio>
#include<cstring>
using namespace std;
int a[50];
int main()
{
    int t,m;
    long long n;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%I64d", &m, &n);
        memset(a, 0, sizeof(a));
        for (int i = 1; i <= m; i++)
        {
            a[i] = n % 3;
            n /= 3;
        }
        for (int i = m; i >= 1; i--)
        {
            if (a[i] == 0)printf("R");
            else if (a[i] == 1)printf("G");
            else printf("B");
        }
        printf("\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值