玲珑学院 1058 - Coco

DESCRIPTION

Coco just learned a math operation call mod.Now,there is an integer aa and nn integers b1,,bnb1,…,bn. After selecting some numbers from b1,,bnb1,…,bn in any order, say c1,,crc1,…,cr, Coco want to make sure that amodc1modc2modmodcr=0amodc1modc2mod…modcr=0\ (i.e., aa will become the remainder divided by cici each time, and at the end, Coco want aa to become 00). Please determine the minimum value of rr. If the goal cannot be achieved, print 1−1 instead.

INPUT
The first line contains one integer T(T5)T(T≤5), which represents the number of testcases. For each testcase, there are two lines:1. The first line contains two integers nn and aa\ ( 1n20,1a1061≤n≤20,1≤a≤106).2. The second line contains nn integers b1,,bnb1,…,bn\ ( 1in,1bi106∀1≤i≤n,1≤bi≤106).
OUTPUT
Print TT answers in TT lines.
SAMPLE INPUT
22 92 72 96 7
SAMPLE OUTPUT
2-1
SOLUTION
对于一组可能的答案 cc ,如果先对一个觉小的 cici 取模,再对一个较大的 cjcj 取模,那么这个较大的 cjcj 肯定是没有用的。因此最终的答案序列中的 cc 肯定是不增的。那么就枚举选哪些数字,并从大到小取模看看结果是否是 00 就可以了。时间复杂度 O(2n)O(2n) .
代码

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAXN = 1000010;
int a[MAXN],vis[MAXN],N,ans;
void dfs(int x,int cut)
{
    if(x == 0)
    {
        ans = cut;
        return;
    }
    for(int i = 0 ; i < N && a[i] <= x; i++)
    {
        if(!vis[x % a[i]])
            vis[x % a[i]] = 1,dfs(x % a[i],cut + 1);
        if(ans != -1) return;
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int A;
        scanf("%d %d",&N,&A);
        for(int i =0; i <N; i++) scanf("%d",&a[i]);
        memset(vis,0,sizeof(vis));
        ans = -1;
        sort(a,a+N);
        dfs(A,0);
        printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值