Parity
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3354 Accepted Submission(s): 2529
Problem Description
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of
0's does not affect the parity of a bit string.
0's does not affect the parity of a bit string.
Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.
Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the letter was 'o').
Sample Input
101e 010010o 1e 000e 110100101o #
Sample Output
1010 0100101 11 0000 1101001010
Source
题意:
统计每组数中的1的个数
e是指判断1的个数为偶数 为真 变成0
为假 变成1
o是指判断1的个数为奇数 为真 变成0
为假 变成1
注意:
1:水题
#include<stdio.h>
#include<math.h>
#include<string.h>
int main (void)
{
int i,sum=0;
char a[34];
int leng;
while(~scanf("%s",a))
{
sum=0;
if(a[0]=='#')
return 0;
leng=strlen(a);
for(i=0;i<strlen(a)-1;i++)
{
sum+=a[i]-'0';printf("%c",a[i]);
}
if(((sum%2==0)&&(a[leng-1]=='e'))||((sum%2==1)&&(a[leng-1]=='o')))
{
printf("0\n");
}
else
{
printf("1\n");
}
}
return 0;
}