数据结构基础—Pop Sequence

02-线性结构3 Reversing Linked List(25 分)
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

#include <stdio.h>
#include <stdlib.h>
#include <stdbool.h>
#define ERROR -1
typedef struct LNode{
    int *Data;
    int top;
    int capacity;
}Node;
typedef Node* Stack;

bool isEmpty(Stack S){
    return (S->top == -1);
}

int top(Stack S){
    if (!isEmpty(S)) {
        return (S->Data[S->top]);
    }else return -1;
}

int push(Stack S, int X){
    if ((S->capacity)-(S->top)==1)
        return -1;
    S->Data[++(S->top)] = X;
    return 1;
}

void pop(Stack S){
    if(!isEmpty(S)){
        (S->top)--;
    }
}

void dispose(Stack S){
    free(S);
}

int M,N,K; /* Stack with size M; N numbers in one row; K rows */
int popsequence(Stack S, int* a);
int main(int argc, const char * argv[]) {
    int a[10000];
    int flag;
    scanf("%d%d%d",&M,&N,&K);
    Stack S= (Stack)malloc(sizeof(Node));
    S->Data = (int *)malloc(M*sizeof(int)); /*a stack only can store M numbers*/
    S->capacity = M;
    while (K) {
        S->top = -1;  /* reset the stack */
        K--;
        for (int i = 0; i <= N-1; i++)
            scanf("%d",&a[i]);
        flag = popsequence(S,a);
        if (flag == 1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    dispose(S); /* free the stack */
    return 0;
}

int popsequence(Stack S, int* a){
    int count = 0;
    int flag = 1;
    for(int i = 1;i <= N; i++) {
        if (!push(S,i)) {
            flag = 0;
            return flag;
        }
        while(top(S) == a[count]) {
            pop(S);
            count++;
        }
    }
    if (isEmpty(S)) 
        flag = 1;  /* 最后应该是空 */
    else           
        flag = 0;
    return flag;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值