zoj3872(dp)

Beauty of Array

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21
38

题意:
定义Beauty数是一个序列里所有不相同的数的和,求一个序列所有字序列的Beauty和  1 <= N <= 100000

思路:数据太大无法暴力,想到dp但是状态转移方程实在难搞,看了别人博客才发现——输入dii个数x,dp[i]=(i-a[x])*x+dp[i-1]。dp[i]表示i以及i之前包含i的不同序列不同数数之和,a[x]表示上次出现x的位置。这样dp[i]只比dp[i-1]多出一个因素a[x],它需要加的次数是自从上次x出现的位置后的序列数。

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define ll unsigned long long
int n;
ll a[100010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(a,0,sizeof(a));
		ll sum=0,dp=0;
		int x;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&x);
			dp=(i-a[x])*x+dp;
			sum+=dp;
			a[x]=i;
		}
		printf("%llu\n",sum);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值