PAT 乙 1043 输出PATest(测试通过)

1043 输出PATest (20 分)

给定一个长度不超过 10​4​​ 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过 10​4​​ 的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

PATestPATestPTetPTePePee

总结:对每个字母建立统计数组,打印时顺序打印再将数字减1

#include<iostream>
#include<string.h>
#include<vector>
using namespace std;
int main()
{string str;        
int len,indux[6]={0}; 
 cin>>str;
 len=strlen(&str[0]); 
for(int i=0;i<len;i++)
{  if(str[i]=='P')
   indux[0]= indux[0]+1;
   else if(str[i]=='A')
   indux[1]= indux[1]+1;
   else if(str[i]=='T')
   indux[2]= indux[2]+1;
   else if(str[i]=='e')
   indux[3]= indux[3]+1;
   else if(str[i]=='s')
   indux[4]= indux[4]+1;
   else if(str[i]=='t')
   indux[5]= indux[5]+1;
}
while(indux[0]!=0||indux[1]!=0||indux[2]!=0||indux[3]!=0||indux[4]!=0||indux[5]!=0)	
{
if(indux[0]!=0)
{cout<<"P";	indux[0]=indux[0]-1;
}
if(indux[1]!=0)
{cout<<"A";	indux[1]=indux[1]-1;
}
if(indux[2]!=0)
{cout<<"T";	indux[2]=indux[2]-1;
}
if(indux[3]!=0)
{cout<<"e";	indux[3]=indux[3]-1;
}
if(indux[4]!=0)
{cout<<"s";	indux[4]=indux[4]-1;
}
if(indux[5]!=0)
{cout<<"t";	indux[5]=indux[5]-1;
}			
}
return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值