ZCCZCC Loves Codefires

ZCC Loves Codefires

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137". It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and 
immediately became his fan. But why? Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of 
time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. 
He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the 
achievement in the field of Data Structures. After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible. What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if
Memset137 solves the
problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time. Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program 
to calculate the minimal score he will lose.(that is, the sum of Ki*Ti).
 

Input
  
  
The first line contains an integer N(1≤N≤10^5), the number of problem in the round. The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem. The last line contains N integers Ki(1≤Ki≤10^4), as was described.
 

Output
  
  
One integer L, the minimal score he will lose.
 

Sample Input
  
  
3 10 10 20 1 2 3
 

Sample Output
  
  
150
题意:每一个题目有两个权值,要求计算在使用时间之内,找出使用时间和得分最大,计算出时间/题的值,存着,从大到小排序,再将题从大到小排序,依次计算和。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#define N 100005
using namespace std;


struct node
{
    int k,e;
    double f;
};
bool cmp(node a,node b)
{
    return a.f<b.f;
}
node a[N];
int main()
{
    __int64 sum=0,ans=0;
    int n;
    while(scanf("%d",&n)==1)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i].e);
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i].k);
            a[i].f=1.0*a[i].e/a[i].k;
        }
        sort(a,a+n,cmp);
        for(int i=0;i<n;i++)
        {
            ans+=(sum+a[i].e)*a[i].k;
            sum+=a[i].e;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值