POJ 3660 Cow Contest 传递闭包

Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10062 Accepted: 5678

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

    题意:给出一些关系,求最终能够得到奶牛名次的奶牛的个数。

    分析:一头牛只有在间接或者直接跟所有的奶牛发生关系之后才能确定其最终名次。间接比较:a>b b>c 则a>c。所以该题是一道传递闭包类型的题目。使用二维矩阵保存两者是否发生对比。在判断是否该奶牛与所有奶牛发生关系时,只需要计算该点的出度和入度之和是否等于n-1即可。见AC代码:

//该题的意思是确定最终能确定名次的牛的个数
//一头牛只有在于所有人发生对比之后 才会产生最终名次
// a>b  b>c 所以 a>c
//使用传递闭包
#include<stdio.h>
#include<string.h>
const int maxn=105;
int map[maxn][maxn];
int n,m;
void floyd()
{
	for(int k=1; k<=n; k++)
		for(int i=1; i<=n; i++)
			for(int j=1; j<=n; j++)//若存在  i 到 k  和 k到 j 则 i到j存在关系
				map[i][j]=map[i][j]||(map[i][k]&&map[k][j]);
}
int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		memset(map,0,sizeof(map));
		int s,e;
		for(int i=0; i<m; i++)
		{
			scanf("%d%d",&s,&e);
			map[s][e]=1;
		}
		floyd();
		int res=0,cnt;
		for(int i=1; i<=n; i++)
		{
			cnt=0;
			for(int j=1; j<=n; j++)
				if(map[i][j])//出度
					cnt++;
			for(int j=1; j<=n; j++)
				if(map[j][i])//入度
					cnt++;
			if(cnt==n-1)//所有点有联系
				res++;
		}
		printf("%d\n",res);
	}
}
    时不我待,认真刷题。

    特记下,以备后日回顾。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值