C - Cow Contest

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2   
给你n只牛,每只牛的技能的强弱不一样。现在给你m组牛的胜负关系,问你可以确定多少只牛的技能的排名。
先用floyd将存在的间接关系变为直接关系,例如i和k有关系,k和j有关系,那么通过floyd可以直接得到i和j也有关系。然后再遍历每一只牛,如果他和每一只牛的关系都确定了,那么他的排名必然就能确定        
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;
int g[110][110],out[110];
int n,m;
void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                g[i][j]=g[i][j]||(g[i][k]&&g[k][j]);
        }
    }
}
int main()
{
    ///freopen("1.txt","r",stdin);
    while(cin>>n>>m)
    {
        memset(g,0,sizeof(g));
        for(int i=1;i<=m;i++)
        {
            int x,y;cin>>x>>y;
            g[x][y]=1;
        }
        floyd();
        int co=0;
        for(int i=1;i<=n;i++)
        {
            int flag=0;
            for(int j=1;j<=n;j++)
                if(g[i][j]||g[j][i])flag++;
            if(flag==n-1)co++;
        }
        cout<<co<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值