POJ-3368 Frequent values

原题链接

Frequent values
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16324 Accepted: 5935

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

这道题是RMQ问题,ST算法变形实现。用num[]存储题题中给出的一串数,d[i][j] = max(max(d[i][j-1], d[i+(1<<(j-1)][j]), h), h表示num[i+(1<<(j-1)]在数组num[]中下标i到i+(1<<j)中的连续长度,用二分实现。

查询输出时,也要这样考虑。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define maxn 100005
using namespace std;

int num[maxn], n, q;
int d[maxn][20];
int solve(int l, int r, int p){
	
	int m1 = l, m2 = r;
	while(l < r){
	  	int mid = (l + r) >> 1;
	  	if(num[mid] <= p)
	  	  l = mid + 1;
	  	else
	  	 r = mid;
	}
	int m = l;
	l = m1, r = m2;
	while(l < r){
	  	int mid = (l + r) >> 1;
	  	if(num[mid] >= p)
	  	 r = mid;
	  	else
	  	  l = mid + 1; 
	}
	return m - l;
}
void ST(){
	
	for(int i = 0; i < n; i++){
		d[i][0] = 1;
	}
	for(int j = 0; (1<<j) <= n; j++)
	  for(int i = 0; i+(1<<j) <= n; i++){
	  	int p = num[i+(1<<(j-1))];
	  	int l = i, r = l + (1<<j);
	  	int h = solve(l, r, p);
		d[i][j] = max(h, max(d[i][j-1], d[i+(1<<(j-1))][j-1])); 
	  }
}
int main(){
	
//	freopen("in.txt", "r", stdin);
	while(scanf("%d", &n) == 1){
		if(n == 0)
		 break;
		scanf("%d", &q);
		int a, b;
		for(int i = 0; i < n; i++)
		 scanf("%d", num+i);
		ST();
		while(q--){
			scanf("%d%d", &a, &b);
			a--;
			b--;
			int k = 0;
			while(1<<(k+1) <= b - a + 1)
			 k++;
			int h = solve(a, b+1, num[a+(1<<k)-1]);
			printf("%d\n", max(max(d[a][k], d[b-(1<<k)+1][k]), h));
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值