Parencodings(POJ1068 )

Let S = s1 s2…s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2…pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2…wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S		(((()()())))

P-sequence	    4 5 6666

W-sequence	    1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

题目大意:

解题思路: 括号的模拟,根据右括号的位置从后向前查找,左右括号数量相等时查找停止,左括号或右括号数就是每次匹配的括号数( the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). )

代码

#include<stdio.h>
#include<string.h>
#define SF(n) scanf("%d",&n)
#define INT int
int main()
{
    INT a[1234],right[1234],b[1234];
    char s[1234];
    INT i,J,t,n;
    SF(t);
    while(t--)
    {
        SF(n);
        memset(s,'(',sizeof(s));
        memset(a,0,sizeof(a));
        memset(right,0,sizeof(right));  //右括号的位置
        for(i=1; i<=n; ++i)
        {
            if(i==0)
            {
                SF(a[i]);
                right[i] = a[i]+1;
            }
            else
            {
                SF(a[i]);
                right[i] = right[i-1] + a[i] - a[i-1] + 1;
            }
        }

        for(i=n; i>=1; --i) //模拟括号
        {
            s[right[i]] = ')';
        }
        /*
        for(i=1; i<=right[n]; ++i)
            printf("%c",s[i]);  */

        int l = 0;
        int r = 0;
        int ans = 0;
        int k = 0;
        for(i=1; i<=n; ++i)		//根据右括号的位置
        {
            for(J=right[i]; J>=1; --J)	//从后往前查找
            {
                if(s[J]==')')
                    r++;
                else if(s[J]=='(')
                    l++;
                if(l==r)     //左括号和右括号数量相等时停止
                    break;
            }
            b[k++] = r;     //答案存到一个数组里
            l = 0;
            r = 0;
        }

        for(i=0; i<k; ++i)
        {
            printf("%d",b[i]);
            if(i!=k-1)
                printf(" ");
            else
                printf("\n");
        }

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

葛济维的博客

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值