Parencodings

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24682 Accepted: 14520

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

这个题又是看了好长时间的题意,我的内心时崩溃的QAQ,又是大家一块翻译了翻译。所谓P就是第一个右括号前面的左括号的个数。

然后W就是右括号匹配之前的所有的左括号的个数。哦嚯嚯模拟一下顺着来就可以出结果了~

我们先模拟括号,每次模拟到一个右括号,然后从这个右括号开始,往左去,右括号累计match++,左括号就match--,并且此时sum++(记录左括号)当match=0时退出。w[i]=sum;

最后输出w[i]即可.

#include <stdio.h>
#include <string.h>
int origin[30];
int p[30], w[30];
int t = 0, n = 0;
int main()
{
    int i,j;
    while (~scanf("%d", &t)&&t > 0)
    {
        while (t--)
        {
            scanf("%d", &n);
            int cnt = 0;
            for ( i = 0; i < n ; i++)     scanf("%d", &p[i]);
            for ( i = 0; i < n ; i++)
            {
                int left = i > 0 ? p[i] - p[i - 1] : p[i];
                for ( j = 0; j < left; j++) origin[cnt++] = 0;
                origin[cnt++] = 1;
                int match = 0,sum = 0;
                for ( j = cnt - 1; j >= 0; j--)
                {
                    if (origin[j] == 1)
                    {
                        match++;
                    }
                    else
                    {
                        match--;
                        sum++;
                    }
                    if (!match) break;
                }
                w[i] = sum;
            }

            printf("%d",w[0]);
            for (i = 1; i < n ; i++)  printf(" %d", w[i]);
            printf("\n");
        }
    }
    return(0);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值