1119. Pre- and Post-order Traversals (30) (先序+后序,确定二叉树?)

题目地址

https://www.patest.cn/contests/pat-a-practise/1119

题目描述

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line “Yes” if the tree is unique, or “No” if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

ac思路

先序+后序 无法判断二叉树的唯一性

比如有两个节点的时候,

先序: 根 左
后序: 左 根

或者

先序:根 右
后序:右 根

所以 需要明确是否会出现上述情况

  • 先序第一个节点是根节点,紧接着第二个节点是根节点的左节点还是右节点了?

  • 在后序中查找 先序中的第二个节点

    • 如果后序中的该位置 到 最后(也就是后序中根节点位置) 还有其他数的话,可以判断,先序中第二个节点肯定左节点(反证法。。。)
1 2 3 4
2 4 3 1

1 为 根,2 接着,2在后序中,与1隔着两个数,所以2一定是1的左节点; 3,4成为1的右子树节点

  1
 / 
2
  • 当中间没有数的时候,就不确定了
    例如 3,4
  1
 /  \
2    3
    /
   4

还是

  1
 /  \
2    3
      \
       4

ac代码1

#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <queue>
#include <algorithm>
#include <sstream>
#include <list>
#include <stack> 
#include <map> 
#include <set> 
#include <iterator> 
#include <unordered_map>

using namespace std;

const int INF = 0x7fffffff;

typedef long long int LL;

const int N = 10000 + 5;

int n;

vector<int> preOrder;
vector<int> postOrder;

bool flag;

typedef struct node{
    int val;
    struct node* left;
    struct node* right;
    node(int _val = -1)
    {
        val = _val;
        left = NULL;
        right = NULL;
    }
}Bnode;

Bnode* Create(int preL, int preR, int postL, int postR)
{
    if(preL > preR)
        return NULL;

    Bnode* root = new Bnode(preOrder[preL]);
    if(preL == preR)
        return root;

    // 后序找 pre[preL + 1]
    int k;
    for (k = postL; k < postR; k++)   
    {  
        if (postOrder[k] == preOrder[preL + 1])
            break;  
    }  

    if(postR - k - 1 > 0)
    {
        root->left = Create(preL + 1, preL + 1 + k - postL , postL, k);
        root->right = Create(preL + 1 + k - postL + 1, preR, k+1, postR -1);
    }else{
        flag = false;
        root->right = Create(preL + 1, preR, postL, postR - 1); 
    }

    return root;
}

vector<int> in;
void inOrder(Bnode* root)
{
    if(root != NULL)
    {
        inOrder(root->left);
        in.push_back(root->val);
        inOrder(root->right);
    }
}

int main()
{
    //freopen("in.txt", "r" , stdin);

    while(scanf("%d", &n) != EOF)
    {
        preOrder.clear();
        postOrder.clear();

        int tmp;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &tmp);
            preOrder.push_back(tmp);
        }
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &tmp);
            postOrder.push_back(tmp);
        }
        flag = true;
        Bnode* root = Create(0, n-1, 0, n-1);

        if(flag)
        {
            printf("Yes\n");
        }else{
            printf("No\n");
        }
        in.clear();
        inOrder(root);
        printf("%d", in[0]);
        for(int i=1;i<n;i++)
        {
            printf(" %d",in[i]);
        }
        printf("\n");
    }
    return 0;
}

ac代码2

#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <queue>
#include <algorithm>
#include <sstream>
#include <list>
#include <stack> 
#include <map> 
#include <set> 
#include <iterator> 
#include <unordered_map>

using namespace std;

const int INF = 0x7fffffff;

typedef long long int LL;

const int N = 10000 + 5;

int n;

vector<int> preOrder;
vector<int> postOrder;

bool flag;

typedef struct node{
    int val;
    struct node* left;
    struct node* right;
    node(int _val = -1)
    {
        val = _val;
        left = NULL;
        right = NULL;
    }
}Bnode;

Bnode* Create(int preL, int preR, int postL, int postR)
{
    if(preL > preR)
        return NULL;

    Bnode* root = new Bnode(preOrder[preL]);
    if(preL == preR)
        return root;

    int k;
    for (k = preL + 1; k <= preR; k++)   
    {  
        if (preOrder[k] == postOrder[postR - 1])
            break;  
    }  

    // post[postR -1]是根节点post[postR]的 左或者右 节点
    // 如果先序中,post[postR-1] 前面还有其他节点的话,可以判断其是根节点的左子树,是确定的
    // 否则, post[postT-1] 可以是根节点的左或者右节点
    if( k - preL - 1 > 0)
    {
        root->left = Create(preL + 1, k-1, postL, postL + k - preL -2);
        root->right = Create(k, preR, postL + k - preL -1, postR -1);
    }else{
        flag = false;
        root->right = Create(k, preR, postL + k - preL - 1, postR - 1); 
    }

    return root;
}

vector<int> in;
void inOrder(Bnode* root)
{
    if(root != NULL)
    {
        inOrder(root->left);
        in.push_back(root->val);
        inOrder(root->right);
    }
}

int main()
{
    freopen("in.txt", "r" , stdin);

    while(scanf("%d", &n) != EOF)
    {
        preOrder.clear();
        postOrder.clear();

        int tmp;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &tmp);
            preOrder.push_back(tmp);
        }
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &tmp);
            postOrder.push_back(tmp);
        }
        flag = true;
        Bnode* root = Create(0, n-1, 0, n-1);

        if(flag)
        {
            printf("Yes\n");
        }else{
            printf("No\n");
        }
        in.clear();
        inOrder(root);
        printf("%d", in[0]);
        for(int i=1;i<n;i++)
        {
            printf(" %d",in[i]);
        }
        printf("\n");
    }
    return 0;
}

参考思路
小菜在切题
http://www.cnblogs.com/demian/p/6103285.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值