HDOJ/HDU 1073 Online Judge(字符串处理~)

324 篇文章 134 订阅
315 篇文章 4 订阅

Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user’s result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return “Accepted”, else if the only differences between the two files are spaces(’ ‘), tabs(‘\t’), or enters(‘\n’), the Judge System should return “Presentation Error”, else the system will return “Wrong Answer”.

Given the data of correct output file and the data of user’s result file, your task is to determine which result the Judge System will return.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user’s result file. Both of them are starts with a single line contains a string “START” and end with a single line contains a string “END”, these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output
For each test cases, you should output the the result Judge System should return.

Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END

Sample Output
Presentation Error
Presentation Error
Wrong Answer
Presentation Error

就是输入输出,简单的判断PE,WA,AC这几种情况。

START是开始输入了,
END是结束输入了。数据在这个之间!
每一组有2个 START和END。
就是判断这2个之间的数据是PE,WA还是AC。

分析:
用2字符串分别存储这2个需要比较的数据,遇到换行需要在字符串中加入’\n’。
先看这2个字符串是不是相等,如果相等,就是AC。
不相等,再来判断是PE还是WA。

import java.util.Scanner;
/**
 * @author 陈浩翔
 *
 * 2016-5-26
 */
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        sc.nextLine();
        while (t-- > 0) {
            String a = "";
            String b = "";
            while (true) {
                String str = sc.nextLine();
                if ("END".equals(str)) {
                    break;
                }
                if ("START".equals(str)) {
                    continue;
                }
                a=a+str;
                a=a+"\n";
            }

            while (true) {
                String str = sc.nextLine();
                if ("END".equals(str)) {
                    break;
                }
                if ("START".equals(str)) {
                    continue;
                }
                b=b+str;
                b=b+"\n";
            }
            int con = 0;// -1--PE,0--WA,1--AC

//          System.out.println(a);
//          System.out.println(a.length());
//          System.out.println(b);
//          System.out.println(b.length());

            if(a.equals(b)){
                con=1;
            }else{
                con=-1;
                String stra="";
                for(int i=0;i<a.length();i++){
                    if(a.charAt(i)==' '||a.charAt(i)=='\t'||a.charAt(i)=='\n'){
                        continue;
                    }
                    stra=stra+a.charAt(i);
                }
                String strb="";
                for(int i=0;i<b.length();i++){
                    if(b.charAt(i)==' '||b.charAt(i)=='\t'||b.charAt(i)=='\n'){
                        continue;
                    }
                    strb=strb+b.charAt(i);
                }
//              System.out.println(stra);
//              System.out.println("-------------");
//              System.out.println(strb);
                if(stra.equals(strb)){
                    con=-1;
                }else{
                    con=0;
                }
            }


            if(con==0){
                System.out.println("Wrong Answer");
            }else if(con==-1){
                System.out.println("Presentation Error");
            }else{
                System.out.println("Accepted");
            }
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

谙忆

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值