ZJU PTA ds 7-1 Pop Sequence

7-1 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include <stdio.h>

int IsPopSequence(int *sequence, int n, int m);

int main()
{
    int m, n, k;
    scanf("%d%d%d", &m, &n, &k);

    int sequence[n];
    for (int i = 0; i < k; i++) {
        for (int j = 0; j < n; j++) {// read a sequence
            scanf("%d", &sequence[j]);
        }
        if (IsPopSequence(sequence, n, m) == 1) {// check if a given sequence of numbers is a possible pop sequence of the stack
            printf("YES\n");
        }
        else {
            printf("NO\n");
        }
    }
    return 0;
}

int IsPopSequence(int *sequence, int n, int m)
{
    if (n == 0) {
        return 0;
    }
    int isChecked[1001] = {0};// 已经pop出去的标记为1

    int top = 0;// the top pointer, if top = 0, the stack is empty
    int count = 0;// record the number of elements in the stack.

    if (sequence[0] <= m) {// check the first element
        isChecked[sequence[0]] = 1;
        top = sequence[0] - 1;
        count = top;
    }
    else {
        return 0;
    }

    for (int i = 1; i < n; i++) {
        
        if (top > 0 && sequence[i] == top) {// judge if it want to pop the current top
            // 找到新的top位置
            isChecked[top] = 1;// 将此位置标记
            count--;
            int k = 1;
            while (top - k >= 0 && isChecked[top - k] != 0) {
                k++;
            }
            top = top - k;
        }
        else {// Confirm whether it can be newly added,找到即停
            int toCheckNum = m - count;// 将要check的元素
            int k = 1;
            while (toCheckNum != 0) {
                if (isChecked[top + k] == 0) {
                    toCheckNum--;
                    count++;
                }
                if (top + k == sequence[i]) {
                    isChecked[top + k] = 1;
                    count--;// 标记了后相当于删除了这个元素
                    // 找到新的top位置
                    while (isChecked[top + k - 1] == 1) {
                        k--;
                    }
                    top = top + k - 1;
                    break;
                }
                k++;
            }
        }
    }
    if (count == 0 && top == 0) {
        return 1;
    }
    else {
        return 0;
    }
        
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值