POJ 2385 Apple Catching(基础DP)

Apple Catching

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

分析:

在某一时刻牛的状态为,它可能上一时刻在这棵树下,或者是从另外一棵树走过来的。所以,我们用 dp[i][j] 来表示在第 i 个时刻走了 j 步接到的最多苹果数。暂且不管当前这一时刻是否接到苹果, dp[i][j] = max(dp[i-1][j], dp[i-1][j-1]) ,这描述了我前面说的两种状态。

再看当前这一秒是否接到苹果。因为初始在第一棵树下,因而如果 j 为偶数,即移动了偶数步,那么它应该在第一棵树下,此时如果第一棵树下会掉下一个苹果,那么 dp[i][j] 就要加1。同理如果移动奇数步且第i时刻第二棵树上掉下一个苹果, dp[i][j] 也要加1。

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxt = 1005;
const int maxw = 35;

int dp[maxt][maxw],apple[maxt];

int main()
{
	int t,w,i,j,k;
	while(scanf("%d %d",&t,&w) != EOF){
		for(i = 1;i <= t;i++){
			scanf("%d",&apple[i]);
		}
		memset(dp,0,sizeof(dp));
		for(i = 1;i <= t;i++){
			dp[i][0] = dp[i - 1][0] + 2 - apple[i];
			for(j = 1;j <= w && j <= i;j++){
				if(apple[i] - 1== j % 2)
					dp[i][j] = max(dp[i - 1][j],dp[i - 1][j - 1]) + 1;
				else
					dp[i][j] = max(dp[i - 1][j],dp[i - 1][j - 1]);
			}
		}
		int cnt = 0;
		for(j = 0;j <= w;j++){
			if(cnt < dp[t][j])
				cnt = dp[t][j];
		}
		printf("%d\n",cnt);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值