POJ 3737 UmBasketella(三分)

UmBasketella

Description

In recent days, people always design new things with multifunction. For instance, you can not only use cell phone to call your friends, but you can also use your cell phone take photographs or listen to MP3. Another example is the combination between watch and television. These kinds of multifunction items can always improve people's daily life and are extremely favored by users.

The company Mr. Umbrella invented a new kind umbrella "UmBasketella" for people in Rainbow city recently and its idea also comes from such multifunction--the combination of umbrella and daily necessities. This kind of umbrella can be used as a basket and you can put something you want to carry in it. Since Rainbow city rains very often, such innovative usage is successful and "UmBasketella" sells very well. Unfortunately, the original "UmBasketella" do not have an automatic volume control technology so that it is easily damaged when users try to put too many things in it. To solve this problem, you are needed to design an "UmBasketella" with maximum volume. Suppose that "UmBasketella" is a cone-shape container and its surface area (include the bottom) is known, could you find the maximum value of the cone?

Input

Input contains several test cases. Eash case contains only one real number S, representing the surface area of the cone. It is guaranteed that 1≤S≤10000.

Output

For each test case, output should contain three lines.
The first line should have a real number representing the maximum volume of the cone. 
Output the height of the cone on the second line and the radius of the bottom area of the cone on the third line.
All real numbers should rounded to 0.01.

Sample Input

30

Sample Output

10.93
4.37
1.55
题目大意:给出一个圆锥的表面积(侧面积 + 底面积),求这个圆锥的最大体积、高度和底面半径。

解题思路:圆锥表面积S = πrl + πr ^ 2,体积V = (1 / 3) * hπr ^ 2,由数学知识可以将l和h用r表示出来,进而得到体积关于底面半径的表达式,这是一个单峰函数,三分半径可以得到答案。(PS:因为编译器的原因WA了一上午,G++WA,换成C就AC了)

代码如下:

#include<cstdio>
#include<cmath>
#define eps 1e-8
#define PI acos(-1.0)
double s;


double getH(double r)
{
    double l = s / (PI * r) - r;
	return sqrt(l * l - r * r);
}

double getV(double r)
{
	double h = getH(r);
	return PI * r * r * h / 3;
}

int main()
{
    while(scanf("%lf",&s) != EOF)
    {
        double lb,ub,lm,um;
        lb = 0;
        ub= sqrt(s / PI / 2);
        while(ub - lb > eps)
        {
            lm = (lb + ub) / 2;
            um = (lm + ub) / 2;
            if(getV(lm) > getV(um))
                ub = um;
            else
                lb = lm;
        }
        printf("%.2f\n%.2f\n%.2f\n",getV(lb),getH(lb),lb);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值