A strange lift
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
Sample Input
5 1 5 3 3 1 2 5 0
Sample Output
3
解题思路:双入口BFS。注意处理起始层与目标层相同的情况。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 205;
int k[maxn],cnt[maxn];
int n,a,b;
int bfs()
{
queue<int> que;
que.push(a);
memset(cnt,-1,sizeof(cnt));
cnt[a] = 0;
while(que.size()){
int temp = que.front();
que.pop();
if(temp == b){
return cnt[b];
}
int next_floor;
next_floor = temp + k[temp];
if(1 <= next_floor && next_floor <= n && cnt[next_floor] == -1){
que.push(next_floor);
cnt[next_floor] = cnt[temp] + 1;
}
next_floor = temp - k[temp];
if(1 <= next_floor && next_floor <= n && cnt[next_floor] == -1){
que.push(next_floor);
cnt[next_floor] = cnt[temp] + 1;
}
}
return -1;
}
int main()
{
while(scanf("%d",&n) != EOF && n){
scanf("%d %d",&a,&b);
for(int i = 1;i <= n;i++){
scanf("%d",&k[i]);
}
memset(cnt,0,sizeof(cnt));
int ans = bfs();
printf("%d\n",ans);
}
return 0;
}