HDOJ 1018 Big Number(Stirling公式)

Big Number




Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
题目大意:求一个数的阶乘有多少位数字。

解题思路:
1.设a = log10(n!) ,则n! = 10^a,其中a是一个小数
2.设a = x + y,其中x为整数,y为小数
3. n! = 10^x + 10^y,10^x 肯定为10的倍数,决定了n!的位数。因此,只要知道了a就可以求出n!的位数,而a可以通过斯特林公式求出

代码如下:

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long LL;
const double pi = acos(-1.0);
const double e = exp(1);

LL getDigit(int n)
{
    if(n == 0) return 0;
    double a = 0;
    a = (log10(2 * pi) + log10(n)) / 2 + n * (log10(n) - log10(e));
    return (LL)a + 1;
}


int main(void)
{
    int n,t;
    cin >> t;
    while(t--){
        cin >> n;
        cout << getDigit(n) << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值