ACM--贪心--数学--A-B Game--水


 OJ地址:http://acm.fzu.edu.cn/problem.php?pid=2147


                                               Problem 2147 A-B Game

Accept: 1158    Submit: 2769
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game by two integers A and B. First Fat brother write an integer A on a white paper and then Maze start to change this integer. Every time Maze can select an integer x between 1 and A-1 then change A into A-(A%x). The game ends when this integer is less than or equals to B. Here is the problem, at least how many times Maze needs to perform to end this special (hentai) game.

 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers A and B described above.

1 <= T <=100, 2 <= B < A < 100861008610086

 Output

For each case, output the case number first, and then output an integer describes the number of times Maze needs to perform. See the sample input and output for more details.

 Sample Input

25 310086 110

 Sample Output

Case 1: 1Case 2: 7


===============================华丽的分割线===================================


题意:给出两个数A,B(A>B),每次操作A-(A%x),x任选,问至少需要几次操作能够使得A<B。


解法:简单贪心。每次x都取A/2+1。

代码:


 #include<iostream>
 #include<cstdio>
 #include<stdio.h>
 using namespace std;
 /**
    输入A、B(B<A)。A每次可以进行一次变换:A = A - (A % x)
    ,其中1≤x≤A-1。问最少经过多少次变换,A的值小于等于B。
    这题的要点就是x的取值上面,每次去x=A/2+1是最好的
 */
 int main(void){
    int n,index=0;
    long long  A,B;
    scanf("%d",&n);
    while(n--){
      int result=0;
      cin>>A;
      cin>>B;
      index++;
      while(A>B){
         A=A-(A%(A/2+1));
         result++;
      }
      printf("Case %d: ",index);
      cout<<result<<endl;
    }
     return 0;
 }




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值