1127. ZigZagging on a Tree (30)
Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:8 12 11 20 17 1 15 8 5 12 20 17 11 15 8 5 1Sample Output:
1 11 5 8 17 12 20 15
2.拉链输出,层序遍历,修改层数信息,将遍历结果保存进一个vector数组,索引为层数,输出时层数为奇数则正序输出,偶数则逆序输出。
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
struct TNode{
int left=-1,right=-1;
int lvl;
}tree[100000];
int n,in[31],post[31];
int build(int l1,int r1,int l2,int r2){
int rt = post[r2];
int i = 0;
while(in[i]!=rt) ++i;
int l=i-l1,r=r1-i;
if(l!=0)
tree[rt].left = build(l1,i-1,l2,l2+l-1);
if(r!=0)
tree[rt].right = build(i+1,r1,r2-r,r2-1);
return rt;
}
int main()
{
cin>>n;
for(int i=0;i<n;++i)
cin>>in[i];
for(int i=0;i<n;++i)
cin>>post[i];
int rt = build(0,n-1,0,n-1);
vector<int> lvl[31];
lvl[0].push_back(rt);
tree[rt].lvl=0;
queue<TNode> q;
q.push(tree[rt]);
while(!q.empty()){
TNode tmp = q.front();
q.pop();
if(tmp.left!=-1){
tree[tmp.left].lvl = tmp.lvl+1;
lvl[tmp.lvl+1].push_back(tmp.left);
q.push(tree[tmp.left]);
}
if(tmp.right!=-1){
tree[tmp.right].lvl = tmp.lvl+1;
lvl[tmp.lvl+1].push_back(tmp.right);
q.push(tree[tmp.right]);
}
}
cout<<lvl[0][0];
for(int i=1;i<31;++i){
if(lvl[i].size()==0) break;
if(i%2==0)
for(auto j=lvl[i].rbegin();j!=lvl[i].rend();++j)
cout<<' '<<*j;
else
for(auto j:lvl[i])
cout<<' '<<j;
}
return 0;
}