hdu 6015 Skip the Class

Skip the Class

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 569    Accepted Submission(s): 328


Problem Description
Finally term begins. luras loves school so much as she could skip the class happily again.(wtf?)

Luras will take n lessons in sequence(in another word, to have a chance to skip xDDDD).

For every lesson, it has its own type and value to skip.

But the only thing to note here is that luras can't skip the same type lesson more than twice.

Which means if she have escaped the class type twice, she has to take all other lessons of this type.

Now please answer the highest value luras can earn if she choose in the best way.
 

Input
The first line is an integer T which indicates the case number.

And as for each case, the first line is an integer n which indicates the number of lessons luras will take in sequence.

Then there are n lines, for each line, there is a string consists of letters from 'a' to 'z' which is within the length of 10,
and there is also an integer which is the value of this lesson.

The string indicates the lesson type and the same string stands for the same lesson type.

It is guaranteed that——

T is about 1000

For 100% cases, 1 <= n <= 100,1 <= |s| <= 10, 1 <= v <= 1000
 

Output
As for each case, you need to output a single line.
there should be 1 integer in the line which represents the highest value luras can earn if she choose in the best way.
 

Sample Input
  
  
2 5 english 1 english 2 english 3 math 10 cook 100 2 a 1 a 2
 

Sample Output
  
  
115 3

题意:

终于又开学啦。luras最喜欢的就是开学了,因为这样她又可以愉快地翘课了(啊?)
luras接下来有n节课程需要上(换句话说,可以翘。)
每节课程有相应的课程类型与课程翘课价值。
有一点需要注意的是,luras不可以翘同一类课程超过两次,就是如果这类课已经翘了两次,接下来就一定要上。
问你在这个条件下,luras可以获得的最大翘课价值。

解题思路:最开始我想到了背包,但是当把题读完了发现,其中的课名称(字符串)和价值(整型)相对应,很明显map容器

map<string,int>cnt
我们把课程名和相对应的价值保存在这个map容器所构造出来的cnt数组里,这样我们就可以完美的对他们进行筛选了。

代码:
#include <iostream>
#include <cstring>
#include <map>
using namespace std;
string s;
int b[110][110], v;
int main()
{
    int t;
    while(cin >> t)
    {
        while(t--)
        {
            map<string,int> cnt;
            memset(b, 0, sizeof(b));
            int n, j = 0;
            cin >> n;
            for(int i = 0; i < n; i++)
            {
                cin >> s >> v;
                if(cnt[s]==0) cnt[s] = ++j;
                if(v > b[cnt[s]][0])
                {
                    b[cnt[s]][1] = b[cnt[s]][0];
                    b[cnt[s]][0] = v;
                }
                else if(v > b[cnt[s]][1])
                {
                    b[cnt[s]][1] = v;
                }
            }
            int sum = 0;
            for(int i = 1; i <= j; i++)
            {
                sum+= (b[i][0] + b[i][1]);
            }
            cout << sum << endl;
        }
    }


    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值