Can you solve this equation?
int n;
double a;
cin>>n;
while(n--)
{
cin>>a;
if(a<6||a>807020306||fabs(f(a,0,100))<1e-4)
cout<<"No solution!"<<endl;
else
cout<<fixed<<setprecision(4)<<f(a,0,100)<<endl;
}
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 91 Accepted Submission(s) : 30
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;<br>Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2100-4
Sample Output
1.6152No solution!
题目比起贪心专题的好读多了,只要输入y后输出满足的x首先是这个如果y比6小没有解比x=100大也没有解,范围内的基本的就是二分的
但是题目有精度的要求就一组数据当时没注意这个一口气提交了四个wa。。坑
#include<iostream>
#include<math.h>
#include<iomanip>
using namespace std;
#include<math.h>
#include<iomanip>
using namespace std;
double v(double x)
{
return (8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6);
}
double f(double x,double z, double y)
{
double mid;
while((y-z)>1e-10)
{
mid=(z+y)/2;
if(v(mid)<x)
z=mid+1e-10;
else
y=mid-1e-10;
}
return mid;
{
return (8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6);
}
double f(double x,double z, double y)
{
double mid;
while((y-z)>1e-10)
{
mid=(z+y)/2;
if(v(mid)<x)
z=mid+1e-10;
else
y=mid-1e-10;
}
return mid;
}
int main()
{
int main()
{
int n;
double a;
cin>>n;
while(n--)
{
cin>>a;
if(a<6||a>807020306||fabs(f(a,0,100))<1e-4)
cout<<"No solution!"<<endl;
else
cout<<fixed<<setprecision(4)<<f(a,0,100)<<endl;
}
return 0;
}
}