Assign banana to monkeys

Problem description:

There are N Monkeys and N bananas are placed in a straight line. Each monkey want to have a banana, if two monkeys want to own the same banana, there will be a fight! A monkey can stay at his position, move one step right from x to x + 1, or move one step left from x to x -1. Any of these moves consumes 1 second. Assign monkeys to banana so that not monkey fight each other and the time when the last monkey gets a banana is minimized.

Input:

The input contain two arrays of int. The first array is the positions of monkeys. The second array is the positions of bananas.

Output:

The output is a int, which is the time(in seconds) it takes when all bananas are assigned to monkeys.

Sample input:

 1 3 6
 2 4 6

Sample output:

1

Sample explanation:

Assign monkey at position 1 to banana at position 2. (1 second)

Assign monkey at position 3 to banana at position 4. (1 second)

Assign monkey at position 6 to banana at position 6. (0 second)

Overall time is max(1, 1, 0) = 1 second.

 

方法1,通过数组实现:

#include <iostream>
#include<algorithm>
using namespace std;

int mk[10000000], bn[10000000];//mk猴子,bn香蕉
int main()
{ 
	
	
	int count=0;//当前最大距离差绝对值
	int i=0;

	//依次输入猴子位置,回车结束当前行输入
	while(cin >> mk[i])
	{
			i++;
			if (cin.get() == '\n')
				break;
		
	}
	sort(mk,mk+i);

	//依次输入香蕉位置,回车结束当前行输入
	i = 0;
	while (cin >> bn[i])
	{
			 
			i++;
			if (cin.get() == '\n')
				break;
	
	}
	sort(bn,bn+i);


	//依次比较对应下标位置 猴子移动到对应香蕉 需要的绝对差值,最后选最大的为时间差值
	for (int j = 0; j < i; j++)
	{	
		if(abs(mk[j] - bn[j])>count)
		count=abs(mk[j]-bn[j]);
	}

	cout << count;

	return 0;
}

 方法2,通过vector实现:

#include <iostream>
#include<vector>
#include<algorithm>
using namespace std;

int main()
{
	vector<int> mk, bn;//猴子,香蕉
					   
	int count=0;//当前最大距离差绝对值
	int i;


	while (cin >> i)
	{
		 
		mk.push_back(i);
		if (cin.get() == '\n')
			break;

	}
	sort(mk.begin(), mk.end());
	while (cin >> i)
	{
		 
		bn.push_back(i);
		if (cin.get() == '\n')
			break;

	}
	sort(bn.begin(), bn.end());


	for (int j = 0; j < int(mk.size()); j++)
	{
		if(abs(mk[j] - bn[j])>count)
		count = abs(mk[j] - bn[j]);
	}
	cout << count;
	return 0;
}

两种方法在UOJ平台的测试结果对比:

第一个是使用vector ,第二个是使用数组

 

Vector虽然是动态数组,但是本质上和数组没什么区别,频繁的销毁新建,效率很低,所以正确的做法是新建vector的时候初始化一个合适的大小。vector默认创建给一个初始大小,然后通常按1.5倍增长,因此,此测试例中 vector所占内存 比 自己设定的固定长度数组 内存占用大,耗时间长!

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Hello World程序员

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值