HDU 1097 A hard puzzle 求个位数

原题 http://acm.hdu.edu.cn/showproblem.php?pid=1097

题目:

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34751 Accepted Submission(s): 12481

Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b’s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0< a,b<=2^30)

Output
For each test case, you should output the a^b’s last digit number.

Sample Input
7 66
8 800

Sample Output
9
6

思路:

求a的b次方的个位数的值。

最简单的办法,暴力累乘,但是这样的时间复杂度是O(n),显然TLE。
比如10个2相乘,我们可以看作是两个 5个2相乘再相乘 ,这样我们只需要算到2的5次方再平方即可。
同样5个2相乘,可以看作是两个 2个2相乘再相乘,最后的结果再乘以多余的那个2,。
如此递归下去,时间复杂度就变成了O(logn),为了减少计算量,由于我们只需要个位数,而只有个位数的乘才会影响个位数的结果,所以我们可以每次得到的结果都对10取余,同时也可以防止溢出。显然在int范围不会TLE。

代码:

#include <iostream>
#include"cstdio"
using namespace std;
typedef long long int lint;
lint qiuyu(lint a,lint b)
{
    a=a%10;
    if(b==1)    return a%10;     
    if(b==2)    return ((a%10)*(a%10))%10;
    int x=(qiuyu(a,b/2))%10;
    if(b%2==1)
        return (x*x*a)%10;
    if(b%2==0)
    {
        return (x*x)%10;
    }
}
int main()
{
    lint a,b;
    while(scanf("%I64d %I64d",&a,&b)!=EOF)
    {
        printf("%I64d\n",qiuyu(a,b));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值