hdu 5113: Black And White(dfs+强剪枝)

Black And White

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 3708    Accepted Submission(s): 1008
Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
  
  
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
  
  
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
题目大意:给定一个n*m的棋盘,以及k种颜色,每种颜色的数量都是确定的。各种颜色的数量总和刚好的等于棋盘格的数目。
要求每一个格子的颜色不能和其上下左右的格子的颜色相同。
tip:1. 剩下的格子的数量+1必需是剩余最多种类颜色的两倍,否则必定会有相邻存在。
例如 3*3的空格中,最多的颜色数量不能超过5个
.
2.题目要求只输出一种结果,对应剪枝1。去掉会输出所有可能的结果。
代码:
#include<iostream>
#include<cstring>
using namespace std;
int map[10][10];
int n,m,k;
int flag;
int color[30];
int cnt[30];//统计每个颜色的使用情况 
//方向数组,上下左右四个方向 
const int dire[4][2]={-1,0,1,0,0,-1,0,1};
void dfs(int x,int y)
{	//剪枝1: 
	if(flag)return;
	//剪枝二
	int ans=(n*m-(x-1)*m-y+2)/2;
	for(int i=1;i<=k;i++)
	{
		if(color[i]-cnt[i]>ans)
		return;
	 } 
	 
	if(x==n+1)
	{
		flag=1;
		cout<<"YES"<<endl;
		for(int i=1;i<=n;i++)
			for(int j=1;j<=m;j++)
			{
				if(j==m)cout<<map[i][j]<<endl;
				else cout<<map[i][j]<<" ";
			}
		return;
	 } 
	 
	 //枚举k种颜色 
	for(int i=1;i<=k;i++)
	{
		//如果当前颜色没用使用完毕 
		if(cnt[i]<color[i])
		{
			map[x][y]=i;
			int tag=1;//用于确定是否不同色 
			//枚举四个方向,保证上下左右不同颜色 
			for(int k=0;k<4;k++)//枚举四个方向 
			{
				int nx=dire[k][0]+x;
				int ny=dire[k][1]+y;
				
				//防止地图越界 
				if(nx<1||nx>n||ny<1||ny>m)continue;
			 	
			 	if(i==map[nx][ny])
				 {
				 	tag=0;break;
				  } 
			 } 
			 //即不同色,颜色又没有用完,可以进行涂色 
			 if(tag)
			 {
			 	cnt[i]++;
				if(y<m)dfs(x,y+1);
				else dfs(x+1,1);
				cnt[i]--; 
				map[x][y]=0;
			 }
			 else{
			 	map[x][y]=0;
			 }
		 } 	   
	} 
}
int main()
{
	int t;
	cin>>t;
	for(int z=1;z<=t;z++)
	{
		flag=0;
		memset(map,0,sizeof(map)); 
		memset(cnt,0,sizeof(cnt));
		
		cin>>n>>m>>k;
		for(int i=1;i<=k;i++)
			cin>>color[i];
		cout<<"Case #"<<z<<":"<<endl;
		//从左上角开始搜索 
		dfs(1,1);
	
		if(!flag)
		cout<<"NO"<<endl;
	}
	return 0;
 } 


 
 
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值