hdu5113(dfs+剪枝)

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5113


Black And White

Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1468 Accepted Submission(s): 404
Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1).

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.

Sample Input
  
  
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2

Sample Output
  
  
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1

Source

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;

int n,m,k,flag,t;
int a[30],mat[7][7],vis[7][7];

void dfs(int x, int y, int d)
{
    if (!d)
    {
        flag = 1;
        return ;
    }
    for (int i=1; i<=k; i++)
        if (a[i] > (d+1)/2)
            return ;
    for (int i=1; i<=k; i++)
    {
        if(!a[i])continue;
        if(x&&mat[x-1][y]==i)continue;
        if(y&&mat[x][y-1]==i)continue;
        a[i]--;
        mat[x][y] = i;
        if (y < m-1)
            dfs(x, y+1, d-1);
        else
            dfs(x+1, 0, d-1);
        if (flag)
            return ;
        a[i]++;
    }
    return ;
}

int main ()
{
    int T,ii;
    int i,j;
    scanf ("%d",&T);
    for (ii=1; ii<=T; ii++)
    {
        scanf ("%d%d%d",&n,&m,&k);
        for (i=1; i<=k; i++)
            scanf ("%d",&a[i]);
        flag = 0;
        dfs(0, 0, n*m);
        printf ("Case #%d:\n",ii);
        if (flag)
        {
            printf ("YES\n");
            for (i=0; i<n; i++)
            {
                for (j=0; j<m; j++)
                {
                    if (j==0)
                        printf ("%d",mat[i][j]);
                    else
                        printf (" %d",mat[i][j]);
                }
                printf ("\n");
            }
        }
        else
            printf ("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值