pat甲1122. Hamiltonian Cycle(哈密顿回路+简单dfs)

58 篇文章 0 订阅

1122. Hamiltonian Cycle (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
tips:给定的点数必须是n+1,首尾元素必须
相同,中间不能有重复的点。任意两个点相邻点之间要可达。
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<map>
#include<set>
#include<cmath>
#include<cctype>
#include<stack>
using namespace std;
const int inf=0x3f3f3f3f;

vector<int>g[2000];
int book[10001];
int n,m,t;
int num;
int a[10002];
int flag;//1代表成功,2,0代表不成功 
void dfs(int step){
	if(flag)return;
	if(step==n+1){
		flag=1;
		return ;
		}
	int tgg=1;
	for(int i=0;i<g[a[step]].size();i++){
		if(g[a[step]][i]==a[step+1]){
			dfs(step+1);
			tgg=0;
		}
	}
	
	if(tgg){
		flag=2;return;
	}
	
}
int main(){
	
	cin>>n>>m;
	for(int i=0;i<m;i++){
		int x,y;cin>>x>>y;
		g[x].push_back(y);
		g[y].push_back(x);
	}
	cin>>t;
	for(int i=0;i<t;i++)
	{
		cin>>num;
		flag=0;int tag=0;
		memset(book,0,sizeof(book));
		for(int i=1;i<=num;i++){
			cin>>a[i];
			if(i!=num&&book[a[i]]){
				tag=1;
			}
			book[a[i]]=1;
		}
		
		if(num!=n+1||tag){
		cout<<"NO"<<endl;continue;	
		}
		
		if(a[1]!=a[n+1]){
			cout<<"NO"<<endl;continue;
		}
		
		dfs(1);
		if(flag==1){
			cout<<"YES"<<endl;
			continue;
		}
		else cout<<"NO"<<endl;
		
	}
	
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值