2334:Simple prefix compression

2334:Simple prefix compression

总时间限制: 2000ms 内存限制: 65536kB
描述
Many databases store the data in the character fields (and especially indices) using prefix compression. This technique compresses a sequence of strings A1, …, AN by the following method: if there are strings Ai = ai,1ai,2…ai,p and Ai + 1 = ai+1,1ai+1,2…ai+1,q
such that for some j ≤ min(p, q) ai,1 = ai+1,1, ai,2 = ai+1,2, … ai,j = ai+1,j, then the second string is stored as [j]ai+1,j+1ai+1,j+2… ai+1,q, where [j] is a single character with code j.

If j = 0, that is, strings do not have any common prefix, then the second string is prefixed with zero byte, and so the total length actually increases.

Constraints
1 ≤ N ≤ 10000, 1 ≤ length(Ai) ≤ 255.
输入
First line of input contains integer number N, with following N lines containing strings A1 … AN
输出
Output must contain a single integer – minimal total length of compressed strings.
样例输入
3
abc
atest
atext
样例输出
11

#include<iostream>
#include<string.h>
using namespace std;
//http://bailian.openjudge.cn/practice/2334/
//原来这个题就是一个字符串和它相邻的下一个字符串进行比较
//本来还以为是要全部比较,那就应该是trie树了吧 
char a[11000][300];
int n,cnt=0,len;
int main(){
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>a[i];
        len=strlen(a[i]);
        cnt+=len;//先都加起来 
    }
    for(int i=0;i<n-1;i++){
        for(int j=0;j<min(strlen(a[i]),strlen(a[i+1]));j++){
            if(a[i][j]==a[i+1][j]){
                cnt--;//相同字符就减一 
            }
            else break;
        }
        cnt++;//加j这个字符 
    }
    cout<<cnt<<endl;

} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值