poj 1159 Palindrome -- 回文串,动态规划

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 59029 Accepted: 20505

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

题意是给你一个字符串,让你最少添加多少个字符使得字符串为一个回文串,参考了网上大神们的想法 首先把原始的串反转,然后求这两个串的最长公共子序列,

需要添加的字符=字符串的长度-公共字符串

感觉很好理解,然后写一下最长公共子序列就好了,简单的dp啊

还有中间需要注意的地方,由于题目要求的内存为65536K,要是使用int保存

dp[5005][5005],毫无疑问内存超限了,好多大神写的是滚动数组。本弱弱利用short来存储dp数组,险过啊!!!由于int保存为4个字节,而short只用2个字节来保存,你懂得。

//神奇的short,不会超内存, 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
short dp[5005][5005];
char s1[5005],s2[5005];
int main(){
	int n,i,j;
	int ans;
	while(~scanf("%d",&n)){
		scanf("%s",s1);
		int l = strlen(s1);
		for(i=0;i<l;i++){
			s2[l-i-1]=s1[i];
		}
		s2[l] = '\0';
		memset(dp,0,sizeof(dp));
		for(i=1;i<=l;i++){
			for(j=1;j<=l;j++){
				if(s1[i-1]==s2[j-1]){
					dp[i][j]=dp[i-1][j-1]+1;
				}
				else
					dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
			}
		}
		printf("%d\n",l-dp[l][l]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值