HDU5873 Football Games

题目链接:HDU5873

Football Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1004    Accepted Submission(s): 390


Problem Description
A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced. 
  
  At the first phase of the championships, teams are divided into  M  groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
  
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
 

Input
Multiple test cases, process till end of the input.
  
  For each case, the first line contains a positive integers  M , which is the number of groups.
  The  i -th of the next  M  lines begins with a positive integer  Bi  representing the number of teams in the  i -th group, followed by  Bi  nonnegative integers representing the score of each team in this group.


number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000
 

Output
For each test case, output  M  lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
 

Sample Input
  
  
2 3 0 5 1 2 1 1
 

Sample Output
  
  
F T
 

题意:很多队伍要参加一个比赛,每2个队伍之间都要比赛一次,胜者积2分,平局各一分,负局不得分,问给出的一个得分表中是否会有错误。

题目分析:只需考虑2点,一是总得分数是总局数n*(n-1)的2倍,二是任意m个队伍的得分和一定要大于等于2*m*(m-1),这是因为这2*m*(m-1)是这m支队伍内部互相比赛产生的分数。我们可以进行一次排序,从1到m的得分和是所有m支队伍组合中得分和最小的,判断上述条件是否成立即可。

//
//  main.cpp
//  Football Games
//
//  Created by teddywang on 2016/9/11.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int T,s[20020],n;
int main()
{
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            int flag=1;
            scanf("%d",&n);
            long long int ans=0;
            for(int i=0;i<n;i++)
            {
                scanf("%d",&s[i]);
                ans+=s[i];
            }
            if(ans!=n*(n-1))
                flag=0;
            if(flag!=0) sort(s,s+n);
            long long int cnt=0;
            for(int i=0;i<n;i++)
            {
                cnt+=s[i];
                if(cnt<i*(i+1))
                {
                    flag=0;
                    break;
                }
            }
            if(flag==0) printf("F\n");
            else printf("T\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值