hdu-5873-Football Games

Football Games


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description
A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced. 
  
  At the first phase of the championships, teams are divided into M groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
  
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
 


Input
Multiple test cases, process till end of the input.
  
  For each case, the first line contains a positive integers M, which is the number of groups.
  The i-th of the next M lines begins with a positive integer Bi representing the number of teams in the i-th group, followed by Bi nonnegative integers representing the score of each team in this group.

number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000
 

Output
For each test case, output M lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
 


Sample Input

2
3 0 5 1
2 1 1
 


Sample Output
F
T

题意:
给定M场比赛,每场比赛各个队伍的得分,判断得分是否合理。


题目链接:Football Games
解题思路:
因为两两之间必有一场比赛,那么总场次为C(n,2),所以总分为n*(n-1),最大得分就是打赢其余n-1个队伍,为 2*(n-1), 还有就是两两比赛,两方至少有一个队的分数是在增加的,得分为0的只能有1个队,得分1的只能有2个队,得分为i的只能有i+1的队,满足这三个条件就好了。

代码:

#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>
#include<string>
#include<cmath>
#include<iostream>
#include<map>
#include<queue>
#include<list>


using namespace std;
typedef long long LL;


int main()
{
    int  m, c, fx, flag;
    while(~scanf("%d",&m)) {
        while(m--) {
            scanf("%d",&c);
            map<int,int> mp;
            flag = 1;
            int mx = (c - 1) * 2, res = (c - 1) * c;    //最大分数,总分
            for(int i = 0;i < c;i++) {
                scanf("%d",&fx);
                mp[fx] ++;
                if(mp[fx] > fx+1) { //得分fx不超过fx+1个队
                    flag = 0;
                }
                res -= fx;
                if(res < 0 || fx > mx) {//最大分数,与总分的符合
                    flag = 0;
                }
            }
            if(res != 0) flag = 0;
            if(flag) {
                printf("T\n");
            }
            else {
                printf("F\n");
            }
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值