HDOJ 5651-xiaoxin juju needs help【字符的全排列】

xiaoxin juju needs help

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1132    Accepted Submission(s): 324


Problem Description
As we all known, xiaoxin is a brilliant coder. He knew **palindromic** strings when he was only a six grade student at elementry school.

This summer he was working at Tencent as an intern. One day his leader came to ask xiaoxin for help. His leader gave him a string and he wanted xiaoxin to generate palindromic strings for him. Once xiaoxin generates a different palindromic string, his leader will give him a watermelon candy. The problem is how many candies xiaoxin's leader needs to buy?
 

Input
This problem has multi test cases. First line contains a single integer T(T20) which represents the number of test cases.
For each test case, there is a single line containing a string S(1length(S)1,000) .
 

Output
For each test case, print an integer which is the number of watermelon candies xiaoxin's leader needs to buy after mod 1,000,000,007 .
 

Sample Input
  
  
3 aa aabb a
 

Sample Output
  
  
1 2 1
 

Source
 
解题思路:
我们要找到这个字符串可以组成多少个回文串,当然可以看出字母的个数为奇数的个数超过两个包括两个就输出0.
需要推出一个公式p表示字母数量/2.
#include <cstdio>
#include <cstring>
#define rep(i,j,k) for(i=j;i<k;++i)
typedef long long ll;
const ll mod = 1000000007;
int p[26]; ll a[1001];
char str[1005];
ll quick_pow(ll a, ll b) {
    ll ans = 1;
    for (; b; b /= 2, a = (a * a) % mod)
        if (b & 1) ans = (ans * a) % mod;
    return ans;
}
int main() {
    int t, i, n, odd;
    a[0] = 1;
    rep(i,1,1001) a[i] = (a[i - 1] * i) % mod;
    scanf("%d", &t);
    while (t--) {
        memset(p, 0, sizeof p);
        scanf("%s", str);
        n = strlen(str); odd = -1;
        rep(i,0,n) ++p[str[i] - 'a'];
        ll ans = a[n / 2];
        rep(i,0,26) if (p[i] & 1)
            if (odd == -1) odd = i;
            else { ans = 0; goto end; }
        rep(i,0,26) ans = (ans * quick_pow(a[p[i] / 2], mod - 2)) % mod;
        end: printf("%lld\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值