PAT甲级 1080 Graduate Admission (30 分)排序

113 篇文章 9 订阅
8 篇文章 0 订阅

1080 Graduate Admission (30 分)

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​, and the interview grade G​I​​. The final grade of an applicant is (G​E​​+G​I​​)/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​. If still tied, their ranks must be the same.

  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's G​E​​ and G​I​​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

题目大意:每个考生有两个成绩:GE和GI,最终成绩为(GE + GI) / 2;按照最终成绩排名,如果最终成绩相同,就按照GE排名,如果仍然相同,他们的排名就是相同的。每个申请者有K个选择院校,每个学校也有招生人数限制。按照排名先后,如果当前考生的志愿学校的名额还没满,就录取进去;如果当前志愿名额满了但是该校最后一个录取的人的排名和当前考生相同,则不管招生人数限制,依旧应该被录取;否则考虑该生的下一个志愿。如果所有志愿都没有能被录取,则该生落榜。 

注意:如果时间超时,则在排序函数cmp里参数使用&号!!!像scanf和printf省时一样记住它!

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct node{
	int number,Ge,Gi,score,rank;
	vector<int> choice;
};

bool cmp(node &a,node &b){
	return a.score == b.score? a.Ge > b.Ge : a.score > b.score;
}

bool cmp2(node &a,node &b){
	return a.number < b.number;
}

int main(){
	int n,m,k;
	cin>>n>>m>>k;
	vector<int> vec(m);
	vector<node> stu(n);
	for(int i=0;i<m;i++)
		cin>>vec[i];
	for(int i=0;i<n;i++){
		stu[i].number = i;
		cin>>stu[i].Ge>>stu[i].Gi;
		stu[i].score = (stu[i].Ge + stu[i].Gi)/2;
		stu[i].choice.resize(k);
		for(int j=0;j<k;j++){
			cin>>stu[i].choice[j];
		}
	}
	
	sort(stu.begin(),stu.end(),cmp);
	vector<int> flag(n,0);
	int rank=1;
	stu[0].rank = 1;
	for(int j=1;j<stu.size();j++){
		if(stu[j].score == stu[j-1].score && stu[j].Ge == stu[j-1].Ge)
			stu[j].rank = rank;
		else{
			stu[j].rank = j+1;
			rank = j+1;
		}		
	}
	
	vector<int> num(m,0);
	vector<vector<node>> res(m);
	for(int i=0;i<n;i++){
		if(flag[stu[i].number] == 1) continue;
		for(int j=0;j<k;j++){
			int n = stu[i].choice[j];//志愿id 
			if(num[n] < vec[n]){
				flag[stu[i].number] = 1;
				res[n].push_back(stu[i]);
				num[n]++;
				break;
			}else if(num[n] == vec[n]){//注意这里num[n]不要再加
				node lastStu = res[n][res[n].size()-1];
				if(lastStu.rank == stu[i].rank){                                                                   
					flag[stu[i].number] = 1;
					res[n].push_back(stu[i]);
					break;
				}
			}
		}
	}
	
	for(int i=0;i<m;i++){
		sort(res[i].begin(),res[i].end(),cmp2);
		for(int j=0;j<res[i].size();j++){
			cout<<res[i][j].number;
			if(j != res[i].size()-1)cout<<" ";
		}
		cout<<endl;
	}
	return 0;
} 

下面提供不需要名次排序,直接判断的方法:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct node{
	int number,Ge,Gi,score,rank;
	vector<int> choice;
};

bool cmp(node &a,node &b){
	return a.score == b.score? a.Ge > b.Ge : a.score > b.score;
}

bool cmp2(node &a,node &b){
	return a.number < b.number;
}

int main(){
	int n,m,k;
	cin>>n>>m>>k;
	vector<int> vec(m);
	vector<node> stu(n);
	for(int i=0;i<m;i++)
		cin>>vec[i];
	for(int i=0;i<n;i++){
		stu[i].number = i;
		cin>>stu[i].Ge>>stu[i].Gi;
		stu[i].score = (stu[i].Ge + stu[i].Gi)/2;
		stu[i].choice.resize(k);
		for(int j=0;j<k;j++){
			cin>>stu[i].choice[j];
		}
	}
	
	sort(stu.begin(),stu.end(),cmp);
	vector<int> flag(n,0);
	vector<int> num(m,0);
	vector<vector<node>> res(m);
	for(int i=0;i<n;i++){
		if(flag[stu[i].number] == 1) continue;
		for(int j=0;j<k;j++){
			int n = stu[i].choice[j];//志愿id 
			int lastIndex = vec[n]-1;
			if(num[n] < vec[n] || res[n][lastIndex].score == stu[i].score && res[n][lastIndex].Ge == stu[i].Ge){
				flag[stu[i].number] = 1;
				res[n].push_back(stu[i]);                                                                                                          
				num[n]++;
				break;
			}                                                                                                            
		}
	}
	
	for(int i=0;i<m;i++){
		sort(res[i].begin(),res[i].end(),cmp2);
		for(int j=0;j<res[i].size();j++){
			cout<<res[i][j].number;
			if(j != res[i].size()-1)cout<<" ";
		}
		cout<<endl;
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值