PAT甲级 A1080
解题思路
1080 Graduate Admission (30分)
It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
Each applicant will have to provide two grades: the national entrance exam grade G
E
, and the interview grade G
I
. The final grade of an applicant is (G
E
+G
I
)/2. The admission rules are:
The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G
E
. If still tied, their ranks must be the same.
Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.
Input Specification:
Each input file contains one test case.
Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G
E
and G
I
, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.
Output Specification:
For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.
Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8
1 4
解题思路
这道题需要用到很多排序,对于学生和学校分别建立一个数据结构。学习数据结构需要包括最近录取的学生信息(为最后破格录取做准备)。在先将学生排序,按序读入进行录取即可
以下为AC代码
#include<iostream>
#include<vector>
#include<string>
#include<set>
#include<algorithm>
#include<map>
#include<vector>
#include<iomanip>
#include<queue>
using namespace std;
class student {
public:
int Ge;
int Gi;
int apply[5] = { 0,0,0,0,0 };
int nos;
};
class school {
public:
student lastaccept;
int avai = 0;
vector<int> studentno;
};
int N, M, K;
vector<school> schoolno(200);
vector<student> st;
bool cmp(student a, student b) {
if ((a.Ge + a.Gi) != (b.Ge + b.Gi)) {
return (a.Ge + a.Gi) > (b.Ge + b.Gi);
}
else {
return a.Ge > b.Ge;
}
}
bool issame(student a, student b) {
if (a.Ge == b.Ge && a.Gi == b.Gi) {
return true;
}
return false;
}
int main(){
cin >> N >> M >> K;
for (int i = 0; i < M; i++) {
int nos; scanf_s("%d", &nos);
schoolno[i].avai=nos;
}
for (int i = 0; i < N; i++) {
student temp;
scanf_s("%d%d", &temp.Ge, &temp.Gi);
for (int j = 0; j < K; j++) {
scanf_s("%d", &temp.apply[j]);
}
temp.nos = i;
st.push_back(temp);
}
sort(st.begin(), st.end(), cmp);
for (int i = 0; i < N; i++) {
for (int j = 0; j < K; j++) {
int sch = st[i].apply[j];
if (schoolno[sch].avai > 0) {
schoolno[sch].avai--;
schoolno[sch].studentno.push_back(st[i].nos);
schoolno[sch].lastaccept = st[i];
break;
}
else {
if (issame(st[i], schoolno[sch].lastaccept)) {
schoolno[sch].studentno.push_back(st[i].nos);
break;
}
}
}
}
for (int i = 0; i < M; i++) {
if (schoolno[i].studentno.size() == 0) {
cout << '\n';
}
else {
sort(schoolno[i].studentno.begin(), schoolno[i].studentno.end());
int s = schoolno[i].studentno.size();
for (int j = 0; j < s; j++) {
if (j) {
cout << " ";
}
cout << schoolno[i].studentno[j];
}
cout << '\n';
}
}
}