【PAT甲级】1080 Graduate Admission

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​, and the interview grade G​I​​. The final grade of an applicant is (G​E​​+G​I​​)/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​. If still tied, their ranks must be the same.

  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's G​E​​ and G​I​​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

题目大意

这题题目有点长,主要讲的大意就是毕业季每个有n个应届生,有m个招研究生的学校,每个学生有k个志愿选择。接着给出了m个学校的招生满额人数。然后给出了n行,每行包括这个应届生的两种成绩,以及该学生的k个志愿。接着按照排序规则进行排名,然后按照排名先后进行选择志愿。最后输出每个学校的招生学生信息。

排序规则是:以grade_e+grade_i从大到小为第一优先级,如果相等则按照grade_e从大进行排序,如果都相等则排名相同。

招生规则:

  • 按照排名从前往后依次进行志愿选择
  • 如果第一志愿招生已满,则进行第二志愿、第三志愿...直到被录取,如果都没录取,那该生就很倒霉了。
  • 如果当前志愿已经招满人了,但是之前有和当前学生同排名的学生进入了目标院校,则即便已经招满人了,该生也能进入。

个人思路

还是排序算法的应用,招生过程就按照上述的招生规则进行模拟即可。

代码实现

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define eps 1e-8
#define INF 0x7FFFFFFF

using namespace std;

const int maxm = 105;
const int maxn = 40005;

// 应届生信息结构体
struct Application {
    int id, grade_e, grade_i, rank, school;
    int choice[5];
};

// 应届生排序函数 优先级:(grade_e+grade_i) / 2 > grade_e
bool cmp_app(Application a1, Application a2) {
    if (a1.grade_e+a1.grade_i != a2.grade_e+a2.grade_i)
        return a1.grade_e+a1.grade_i > a2.grade_e+a2.grade_i;
    else
        return a1.grade_e > a2.grade_e;
}

// 学校新收研究生排序,按照id从小到大
bool cmp_member(int a1, int a2) {
    return a1 < a2;
}

int quota[maxm]; // 每个学校满额数量
Application apps[maxn]; // 应届生数组
int admitted[maxm] = {0}; // 每个学校当前接受研究生的数量
vector<int> member[maxm]; // 每个学校当前接受研究生的信息

int main() {
    // 输入
    int n, m, k;
    cin >> n >> m >> k;
    for (int i = 0; i < m; i ++) {
        cin >> quota[i];
    }
    for (int i = 0; i < n; i ++) {
        apps[i].id = i;
        cin >> apps[i].grade_e >> apps[i].grade_i;
        for (int j = 0; j < k; j ++) {
            cin >> apps[i].choice[j];
        }
    }
    // 排序
    sort(apps, apps+n, cmp_app);
    // 排名
    apps[0].rank = 1;
    for (int i = 1; i < n; i ++) {
        if (apps[i].grade_e == apps[i-1].grade_e && apps[i].grade_i == apps[i-1].grade_i)
            apps[i].rank = apps[i-1].rank;
        else
            apps[i].rank = i+1;
    }
    // 按照排名后顺序进行目标院校选择
    for (int i = 0; i < n; i ++) {
        Application a_tmp = apps[i];
        for (int j = 0; j < k; j ++) {
            int choosed = a_tmp.choice[j];
            // 如果目标院校没收满
            if (admitted[choosed] < quota[choosed]) {
                admitted[choosed] ++;
                member[choosed].push_back(a_tmp.id);
                apps[i].school = choosed;
                break;
            }
            // 目标院校已经收满
            else {
                bool flag = false; // 判断是否有同名次的人在这个学校
                int pos = i-1;
                while (a_tmp.rank == apps[pos].rank) {
                    if (apps[pos].school == choosed) {
                        flag = true;
                        break;
                    }
                    pos --;
                }
                // 如果有同名次的人在这个学校该生也能进
                if (flag) {
                    admitted[choosed] ++;
                    member[choosed].push_back(a_tmp.id);
                    apps[i].school = choosed;
                    break;
                }
            }
        }
    }
    // 输出
    for (int i = 0; i < m; i ++) {
        if (admitted[i] != 0) {
            sort(member[i].begin(), member[i].end(), cmp_member);
            for (int j = 0; j < member[i].size(); j ++) {
                cout << member[i][j];
                if (j != member[i].size()-1) cout << " ";
            }
        }
        cout << endl;
    }
    return 0;
}

总结

学习不息,继续加油

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值