HD 1856 More is better 【并查集】

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 19232    Accepted Submission(s): 7074


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
AC代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define max 10000000
int pre[max+10];
int vis[max+10];
int num[max+10];
void init()
{
	for(int i=1;i<=max;i++)
	{
		pre[i]=i;
		num[i]=1;//开始时数量都为1,根节点为自己。 
	}
}
int find(int x)
{
	if(pre[x]!=x)
	{
		pre[x]=find(pre[x]);
	}
	return pre[x];
}
void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
		num[fy]+=num[fx]; //统计一个集合里面的总共有多少个元素。 
	} 
} 
int main()
{
	int k,Max,a,b,m;
	while(scanf("%d",&k)!=EOF)
	{
		if(k==0)
		{
			printf("1\n");
			continue;
		}
		init();
		m=0;
		for(int i=0;i<k;i++)
		{
			scanf("%d %d",&a,&b);
			vis[a]=1;
			vis[b]=1;
			if(a>m)//要找出最多有多少个人,不能用max的值,否则会超内存。 
			m=a;
			if(b>m)
			m=b;
			join(a,b);
		}
		Max=0;
		//for(int i=1;i<=max;i++)
		for(int i=1;i<=m;i++)
		{
			if(num[i]>Max)
				Max=num[i];
		}
		printf("%d\n",Max);
	}	
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值