并查集专栏

How Many Tables(hd 1213)


Today is Ignatius'birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants toknow how many tables he needs at least. You have to notice that not all thefriends know each other, and all the friends do not want to stay withstrangers.

One important rule for this problem is that if I tell you A knows B, and Bknows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C canstay in one table, and D, E have to stay in the other one. So Ignatius needs 2tables at least.

Input

The input startswith an integer T(1<=T<=25) which indicate the number of test cases. ThenT test cases follow. Each test case starts with two integers N andM(1<=N,M<=1000). N indicates the number of friends, the friends aremarked from 1 to N. Then M lines follow. Each line consists of two integers Aand B(A!=B), that means friend A and friend B know each other. There will be ablank line between two cases.

Output

For each testcase, just output how many tables Ignatius needs at least. Do NOT print anyblanks.

Sample Input

2

5 3

1 2

2 3

4 5

 

5 1

2 5

Sample Output

2

4


题意:认识或间接认识的人可以坐在一桌,问需要几桌。

思路:基础并查集题。找到根节点,看有多少根节点就可以了。


#include <iostream>

using namespace std;

int bin[111111];

int find(int x)

{

    if(x==bin[x]) return x;

    return find(bin[x]);

}

void merge(int x,int y)

{

    int fx,fy;

    fx=find(x);

    fy=find(y);

    if(fx!=fy)

        bin[fx]=fy;

}

int main()

{

    int T;

    cin>>T;

    while(T--)

    {

        int c,i,n,m,x,y;

        cin>>n>>m;

        for(i=1;i<=n;i++)

            bin[i]=i;

 

        for(i=1;i<=m;i++)

        {

            cin>>x>>y;

            merge(x,y);

        }

        for(c=0,i=1;i<=n;i++)

        {

            if(bin[i]==i) c++;

        }

        cout<<c<<endl;

    }

    return 0;

}


More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 29125    Accepted Submission(s): 10365


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
 
 
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

 

#include <iostream>
using namespace std;
int bin[111111];
int find(int x)
{
    if(x==bin[x]) return x;
    return find(bin[x]);
}
void merge(int x,int y)
{
    int fx,fy;
    fx=find(x);
    fy=find(y);
    if(fx!=fy)
        bin[fx]=fy;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int c,i,n,m,x,y;
        cin>>n>>m;
        for(i=1;i<=n;i++)
            bin[i]=i;

        for(i=1;i<=m;i++)
        {
            cin>>x>>y;
            merge(x,y);
        }
        for(c=0,i=1;i<=n;i++)
        {
            if(bin[i]==i) c++;
        }
        cout<<c<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值