solution Of 1068. Find More Coins (30)

48 篇文章 0 订阅

1068. Find More Coins (30)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=104, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= … <= Vk such that V1 + V2 + … + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution


结题思路:
题意要求我们找出制定总额的零钱方案。
要求1:实质就是01背包问题(此时,重量和价值等价);
要求2:由于要找出最小的方案,我们需要完全保存整个数组;
要求3:如果我们仅需要知道当前背包能放入的最大的数额,用两个以为数组保存结果即可;
要求4:将硬币的价值从大到小排序,此时得到的可行解即为最小的可行方案。

程序步骤:
第一步、按价值从大到小排序硬币;
第二步、动态规划f[i,j] = Max{ f[i-1,j-Wi]+Wi, f[i-1,j] }
第三步、从最后一行开始进行回溯,得到最小方案,最后输出。

具体程序(AC)如下:

#include <iostream>
#include <vector> 
#include <algorithm>
#define capacity 105
#define coinMaxNum 10005
using namespace std;
unsigned int map[coinMaxNum][capacity]={0};
vector<int> result;//最后结果
int max(int a,int b)
{
    return a>b?a:b;
}
int min(int a,int b)
{
    return a<b?a:b;
}
int cmp(const int& a,const int& b)
{
    return a>b;
}
void getRoadNode(vector<int> &coin,const int row,int col)//回溯查找最小方案
{
    for(int i=row;i>0;--i)
    {
        if(map[i][col]==map[i-1][col-coin[i]]+coin[i])
        {
            result.push_back(coin[i]);
            col-=coin[i];
        }
    }
}
int dp(vector<int> &coin,int num,int totPay)
{
    int start;
    for(int i=1;i<=num;++i)
    {
        start=coin[i];
        for(int j=1;j<start;++j)
            map[i][j]=map[i-1][j];
        for(int j=start;j<=totPay;++j)//在这里才开始进行状态转移的判断
            map[i][j]=max(map[i-1][j],map[i-1][j-start]+start);
    }
    return map[num][totPay];
}
int main()
{
    int num,totPay;
    cin>>num>>totPay;
    vector<int> coin(num+1);
    result.clear();
    for(int i=1;i<=num;++i)
        cin>>coin[i];
    if(num>1)
        sort(coin.begin()+1,coin.end(),cmp);
    int final=dp(coin,num,totPay);
    if(final!=totPay)
        cout<<"No Solution"<<endl;
    else
    {
        getRoadNode(coin,num,totPay);
        cout<<result[0];
        for(int i=1;i<result.size();++i)
            cout<<" "<<result[i];
        cout<<endl;
    }
    return 0;
}

还有一个深搜暴力版的:
brute Search:(大case过不去就是了)

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> value;
vector<int> result;
bool getResult(int cur,int tot)
{
    if(tot==0)
        return true;
    if(tot-value[cur]>=0)
    {
        bool flag;
        result.push_back(value[cur]);
        flag=getResult(cur+1,tot-value[cur]);
        if(flag)
            return true;
        result.pop_back();
        flag=getResult(cur+1,tot);
        if(flag)
            return true;
        return false;
    }
    else
        return false;

}
 int main()
{
    /* code */
    int num,tot;
    cin>>num>>tot;
    value.clear();
    result.clear();
    value.resize(num);
    for(int i=0;i<num;++i)
        cin>>value[i];
    //输入结束
    sort(value.begin(),value.end());
    if(getResult(0,tot))
    {
        cout<<result[0];
        for(int i=1;i<result.size();++i)
            cout<<" "<<result[i];
    }       
    else
        cout<<"No Solution";
    cout<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值