6461:Tak and Cards(数位DP)

6461: Tak and Cards

时间限制: 1 Sec   内存限制: 128 MB
提交: 173   解决: 63
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

Tak has N cards. On the i-th (1≤i≤N) card is written an integer xi. He is selecting one or more cards from these N cards, so that the average of the integers written on the selected cards is exactly A. In how many ways can he make his selection?

Constraints
1≤N≤50
1≤A≤50
1≤xi≤50
N,A,xi are integers.
Partial Score
200 points will be awarded for passing the test set satisfying 1≤N≤16.

输入

The input is given from Standard Input in the following format:
N A
x1 x2 … xN

输出

Print the number of ways to select cards such that the average of the written integers is exactly A.

样例输入

4 8
7 9 8 9

样例输出

5

提示

The following are the 5 ways to select cards such that the average is 8:
Select the 3-rd card.
Select the 1-st and 2-nd cards.
Select the 1-st and 4-th cards.
Select the 1-st, 2-nd and 3-rd cards.
Select the 1-st, 3-rd and 4-th cards.


#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<deque>
#include<ctype.h>
#include<map>
#include<set>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
int n, a, temp;
long long dp[55][3000];
 
int main()
{
    memset(dp, 0, sizeof(dp));
    scanf("%d%d", &n, &a);
    dp[0][0]=1;
    for(int i=1;i<=n;i++)
    {
        scanf("%d", &temp);
        for(int j=i-1;j>=0;j--)
            for(int k=0;k<=55*j;k++)
                dp[j+1][k+temp]+=dp[j][k];
    }
    long long ans=0;
    for(int i=1;i<=n;i++)
        ans+=dp[i][i*a];
    printf("%lld\n", ans);
    return 0;
}
 
/**************************************************************
    Problem: 6461
    User: ldu_reserver201701
    Language: C++
    Result: 正确
    Time:12 ms
    Memory:2984 kb
****************************************************************/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hhjian6666

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值