6486: An Ordinary Game(暴力更新)

6486: An Ordinary Game

时间限制: 1 Sec   内存限制: 128 MB
提交: 150   解决: 75
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

There is a string s of length 3 or greater. No two neighboring characters in s are equal.
Takahashi and Aoki will play a game against each other. The two players alternately performs the following operation, Takahashi going first:
Remove one of the characters in s, excluding both ends. However, a character cannot be removed if removal of the character would result in two neighboring equal characters in s.
The player who becomes unable to perform the operation, loses the game. Determine which player will win when the two play optimally.

Constraints
3≤|s|≤105
s consists of lowercase English letters.
No two neighboring characters in s are equal.

输入

The input is given from Standard Input in the following format:
s

输出

If Takahashi will win, print First. If Aoki will win, print Second.

样例输入

aba

样例输出

Second

提示

Takahashi, who goes first, cannot perform the operation, since removal of the b, which is the only character not at either ends of s, would result in s becoming aa, with two as neighboring.


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int main()
{
    char s[100005], ss[100005];
    scanf("%s", s);
    int sum=0, ans=0, len=strlen(s);
    while(1)
    {
        for(int i=1;i<len-1;i++)
        {
            if(s[i]!='\0')
            {
                int x=i-1; 
                while(s[x]=='\0')   x--;
                if(s[x]!=s[i+1])
                {
                    s[i]='\0';
                    sum++;
                }
            }
        }
        int cnt=0;
        for(int i=0;i<len;i++)
            if(s[i]!='\0')
                ss[cnt++]=s[i];
        for(int i=0;i<len;i++)
            s[i]=ss[i];
        len=cnt;
        if(sum==ans)
            break;
        ans=sum;
    }
    if(sum%2)
        printf("First\n");
    else
        printf("Second\n");
    return 0;
} 
/**************************************************************
    Problem: 6486
    User: ldu_reserver201701
    Language: C++
    Result: 正确
    Time:4 ms
    Memory:1168 kb
****************************************************************/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hhjian6666

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值